Ask Your Question
0

could not find any instance of Visual Studio.

asked 2019-10-02 19:26:02 -0600

Tav_PG gravatar image

Goal:I intend to install ROS2 Dashing on Windows. I am building from source following the instructions in https://index.ros.org/doc/ros2/Instal....

Issue: When running colcon build --merge-install from the Visual Studio Developer Command Prompt each package starts to be built. However, it fails on the same error:

--- stderr: <package>
CMake Error at CMakeLists.txt:2 (project):
  Generator

    Visual Studio 16 2019

  could not find any instance of Visual Studio.

I have added an AMENT_IGNORE file to each package to see if the problem is with an individual package, but the error is occuring in every package.

Thank you in advance for any assistance.

edit retag flag offensive close merge delete

Comments

I am also struggling on similar problem, hope this will help: https://stackoverflow.com/questions/5...

cangyin gravatar image cangyin  ( 2019-12-29 07:46:50 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-01-05 18:48:16 -0600

Tav_PG gravatar image

Apology: Firstly I would like to apologise, I'm under some pressure to get ROS2 installed on Windows, and I am posting some issues that I resolve soon after posting them! (sorry) However, more information for the community is better, just in case someone else runs into the same issue.

Appreciation: Thank you cangyin for your input. You found the solution.

Cause:When following the https://index.ros.org/doc/ros2/Instal... instructions at the "Install Visual Studio" section it states,

Make sure that no C++ CMake tools are installed by unselecting them in the list of components to be installed.

I was slightly confused that the accompanying screenshot in the instructions shows 'Visual C++ tools for CMake' checked. So at this point I thought it would be 'safer' :-) to uncheck all the optional components. This was my downfall.

Solution:

[1] Open Visual Studio

[2] On the menu go to Tools > Get Tools and Features

[3] Make sure the "Desktop development with C++" tab is enabled (checked) under the "Workloads" section

[4] In the right side panel

Thanks again to cangyin

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-10-02 19:26:02 -0600

Seen: 2,023 times

Last updated: Jan 05 '20