Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Apology: Firstly I would like to apologise, I'm under some pressure to get ROS2 installed on Windows, and I am posting some issues that I resolve soon after posting them! (sorry) However, more information for the community is better, just in case someone else runs into the same issue.

Appreciation: Thank you cangyin for your input. You found the solution.

Cause: When following the https://index.ros.org/doc/ros2/Installation/Dashing/Windows-Install-Binary/ instructions at the "Install Visual Studio" section it states,

Make sure that no C++ CMake tools are installed by unselecting them in the list of components to be installed.

I was slightly confused that the accompanying screenshot in the instructions shows 'Visual C++ tools for CMake' checked. So at this point I thought it would be 'safer' :-) to uncheck all the optional components. This was my downfall.

Solution:

[1] Open Visual Studio

[2] On the menu go to Tools > Get Tools and Features

[3] Make sure the "Desktop development with C++" tab is enabled (checked) under the "Workloads" section

[4] In the right side panel

Thanks again to cangyin