teb local planner optimization jumps to goal ignoring obstacles

asked 2019-09-30 09:12:06 -0500

robotjohan gravatar image

I am doing a project with a differential drive robot where I'ver recently started using teb local planner which has worked great except for a single issue.

When giving the robot a nav goal the robot starts out following the global plan more or less, which makes sense since teb optimizes the time and the goal is not inside the local costmap. However, while the goal is still not inside the local costmap the local planner suddenly plans all the way to the goal, in some cases straight through an obstacle. As the obstacle approaches and enters the local costmap teb replans and everything is fine, although jerky. While this works ok for the obstacles I have so far I wonder what will happen if the local planner does this with a horseshoe type obstacle which doesn't fit in the local costmap. Also the jerkyness is a bit of a problem.

To deal with this I tried to make the planner follow the global plan as through the tutorial on http://wiki.ros.org/teb_local_planner...

Local plan goes through obstacle which is outside of the local costmap.

I am using Ubuntu 18.04, ROS melodic and I compiled Teb local planner from source.

edit retag flag offensive close merge delete