running different nodes on different machines

asked 2019-09-13 05:07:28 -0500

june2473 gravatar image

I have cameras nodes that i am running on mobile robot's NUC.

and I have mapping node that i want to run on PC.

Everything is connected, i can see topics from cameras on PC. The problem is that mapping node is running but nothing is actually publishing.

I tried running everything on NUC and it was working.

What should i check? how can i run mapping node on PC?

edit retag flag offensive close merge delete

Comments

Sounds like network settings. Check ROS_IP on both computers.

Mehdi. gravatar imageMehdi. ( 2019-09-13 06:14:52 -0500 )edit

You haven't configured your rosmaster properly. I am guessing if you do rostopic hz/bw or echo you will not get anything, or maybe the topic you are getting are from mapping node subscribing to those topics. You can rostopic info the topic to see which node is publishing and which one subscribing it.

But this is a clear problem of network not configured properly.

Choco93 gravatar imageChoco93 ( 2019-09-13 08:59:02 -0500 )edit

Have you carefully followed all of this: http://wiki.ros.org/ROS/NetworkSetup

billy gravatar imagebilly ( 2019-09-13 23:17:43 -0500 )edit

nope, still does not work. I tried to set ROS_IP on both machines in spite that I already set ROS_HOSTNAME, it didnt help, still the same problem. I can even see cameras image and depth cloud in rviz on PC, but mapping node do nothing, no map data.

june2473 gravatar imagejune2473 ( 2019-09-15 23:58:03 -0500 )edit

Check if your node has subscribed to all the required topic

Choco93 gravatar imageChoco93 ( 2019-09-16 02:55:13 -0500 )edit

why? how my node can not be subscribed to all the required topics? I checked by rosnode info, it is subscribed

june2473 gravatar imagejune2473 ( 2019-09-16 04:52:54 -0500 )edit

If all the topic are available and are subscribed by your node as well, then something wrong with your node

Choco93 gravatar imageChoco93 ( 2019-09-16 05:16:33 -0500 )edit

also I set PC and NUC's hostnames in /etc/hostname to exactly what is ROS_HOSTNAME. Is it relevant? and I also changed hostnames in /etc/hosts.

june2473 gravatar imagejune2473 ( 2019-09-16 05:40:57 -0500 )edit