Apt-get can't find any not installed ROS packages

asked 2019-09-13 01:36:11 -0500

ThimoF gravatar image

I am still new to ROS and gazebo and I am also not a pro on linux so pls help. I was following this https://www.generationrobots.com/blog... tutrial step by step on how to setup a simple robot and connect it with ROS to control the bot. After adding the controllers I got the error:

ERROR: cannot launch node of type [controller_manager/spawner]: controller_manager
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/thifer/catkin_ws/src
ROS path [2]=/opt/ros/kinetic/share

Apparently the problem was that ros-control was not installed. I tried to sudo apt install ros-kinetic-controller-manager ros-kinetic-ros-control ros-kinetic-ros-controllers but none of these packages can be located. It looks like apt can't locate any ros package that is not installed yet. I tried installing packages form source but I get stuck in an endless loop of installing dependencies of dependencies of dependencies all from source. I figured out that the problem should be located in the source.list and source.list.d files but they look exactly like they are supposed to look according to the web.

source.list:

# deb http://ftp.nl.debian.org/debian jessie main

deb http://ftp.nl.debian.org/debian jessie main non-free contrib
deb-src http://ftp.nl.debian.org/debian jessie main non-free contrib

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
# deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main

ros-latest.list: (commented out because duplicate warnings)

# deb http://packages.ros.org/ros/ubuntu jessie main

ros_packages.list:

# This file is managed by Puppet. DO NOT EDIT.
# This is the ros packages repository
deb http://packages.ros.org/ros/ubuntu jessie main

I am using ros kinetic on ubuntu jessie amd64

edit retag flag offensive close merge delete

Comments

Not an answer, but the blog states that

This Tutorial was tested with an Ubuntu 12.10 with ROS Hydro and Gazebo-1.9

all of which have reached their end of lives quite some time ago. I'd imagine that you'd run into some problems with this tutorial

jayess gravatar imagejayess ( 2019-09-13 04:26:35 -0500 )edit

Exactly what command are you running that leads to that first error?

jayess gravatar imagejayess ( 2019-09-13 04:27:58 -0500 )edit