ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Publishing from Workstation but can't echo from turtlebot

asked 2012-05-02 13:50:04 -0500

njavia66 gravatar image


After following the Turtlebot networking setup and verifying that both the workstation and the turtlebot laptop are connected via rostopic list I've run into a problem: On the workstation I run:
rostopic pub -r10 /hello std_msgs/String "hello"
On the turtlebot laptop I run:
rostopic echo /hello

However, nothing prints on the turtlebot laptop. What's even more baffling is that when I run rostopic list on turtlebot I can see /hello listed.

Any help is much appreciated

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2012-05-06 18:56:55 -0500

tfoote gravatar image

Please review the Network Setup wiki page. It sounds like you have not set your ROS_HOSTNAME on the workstation correctly to allow the robot to be able to reach the workstation.

edit flag offensive delete link more

answered 2012-05-02 17:07:36 -0500

karthik gravatar image

Hi, Try rxgraph and see if the nodes are connected.

edit flag offensive delete link more

answered 2012-05-02 23:38:08 -0500

fmarques gravatar image

Have you configured /etc/hosts, I had the same problem because I keep forgeting this step.

edit flag offensive delete link more


How would I start to configure the /etc/hosts

njavia66 gravatar image njavia66  ( 2012-05-03 05:59:37 -0500 )edit

Question Tools


Asked: 2012-05-02 13:50:04 -0500

Seen: 420 times

Last updated: May 06 '12