Ask Your Question
0

Have i built this node correctly with catkin_make_isolated? (Beginner Question)

asked 2019-08-12 09:40:39 -0500

Cyril1234 gravatar image

updated 2019-08-12 12:23:05 -0500

jayess gravatar image

I'm a complete beginner, so please bear with me.

I'm trying to run a RPLidar demo on ROS Melodic. As I already have cartographer in my catkin_ws folder, i can't simply use catkin_make to build the rplidar_ros package. So I built it with catkin_make_isolated:

cyril@PC2016:~/catkin_ws$ catkin_make_isolated --pkg rplidar_ros
Base path: /home/cyril/catkin_ws
Source space: /home/cyril/catkin_ws/src
Build space: /home/cyril/catkin_ws/build_isolated
Devel space: /home/cyril/catkin_ws/devel_isolated
Install space: /home/cyril/catkin_ws/install_isolated
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~  traversing 6 packages in topological order:
~~  - cartographer_ros_msgs
~~  - ceres-solver (plain cmake)
~~  - cartographer (plain cmake)
~~  - cartographer_ros
~~  - cartographer_rviz
~~  - rplidar_ros
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Skipping package: 'cartographer_ros_msgs'
Skipping package: 'ceres-solver'
Skipping package: 'cartographer'
Skipping package: 'cartographer_ros'
Skipping package: 'cartographer_rviz'

==> Processing catkin package: 'rplidar_ros'
==> Building with env: '/home/cyril/catkin_ws/devel_isolated/cartographer_rviz/env.sh'
Makefile exists, skipping explicit cmake invocation...
==> make cmake_check_build_system in '/home/cyril/catkin_ws/build_isolated/rplidar_ros'
==> make -j4 -l4 in '/home/cyril/catkin_ws/build_isolated/rplidar_ros'
[ 22%] Built target rplidarNodeClient
[100%] Built target rplidarNode
<== Finished processing package [6 of 6]: 'rplidar_ros'

This output comes out (I should mention that this is the second time I'm running this command, it might have been different the first time). But it states that target rplidarNode has been built.

Alright. Now I run:

cyril@PC2016:~/catkin_ws$ source devel_isolated/setup.bash

because as I understood, devel is replaced by devel_isolated after using catkin_make_isolated.

And following:

cyril@PC2016:~/catkin_ws$ roslaunch rplidar_ros view_rplidar.launch

now it should start. But I get an error message:

cyril@PC2016:~/catkin_ws$ roslaunch rplidar_ros view_rplidar.launch
... logging to /home/cyril/.ros/log/8208c8b6-bd07-11e9-ba28-46a14c3f4f9e/roslaunch-PC2016-5950.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://PC2016:35323/

SUMMARY
========

PARAMETERS
 * /rosdistro: melodic
 * /rosversion: 1.14.3
 * /rplidarNode/angle_compensate: True
 * /rplidarNode/frame_id: laser
 * /rplidarNode/inverted: False
 * /rplidarNode/serial_baudrate: 115200
 * /rplidarNode/serial_port: /dev/ttyUSB0

NODES
  /
    rplidarNode (rplidar_ros/rplidarNode)
    rviz (rviz/rviz)

ROS_MASTER_URI=http://localhost:11311


**ERROR: cannot launch node of type [rplidar_ros/rplidarNode]: can't locate node [rplidarNode] in package [rplidar_ros]** 


process[rviz-2]: started with pid [5965]
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
[rviz-2] process has finished cleanly
log file: /home/cyril/.ros/log/8208c8b6-bd07-11e9-ba28-46a14c3f4f9e/rviz-2*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done

-----------------------------------------------------------------

Thank you very much for any help you can provide! I'm seriously lost on this... :(

EDIT: After trying for 2 hours, fixed by adding --install into the command. How stupid I am.

But another problem has already shown up... getting no rest here. Good luck to everyone reading this.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-08-12 09:43:11 -0500

Cyril1234 gravatar image

Fixed by this:

cyril@PC2016:~/catkin_ws$ catkin_make_isolated --install --pkg rplidar_ros

instead of:

cyril@PC2016:~/catkin_ws$ catkin_make_isolated --pkg rplidar_ros
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-08-12 09:27:15 -0500

Seen: 27 times

Last updated: Aug 12