Ask Your Question
0

booleans not shown in 'rostopic echo -p /topic'

asked 2012-05-01 06:48:02 -0600

Dr. Love gravatar image

updated 2012-07-02 13:46:28 -0600

mjcarroll gravatar image

My issue was that a boolean field (bool) in my custom message was displayed when using 'rostopic echo /topic_name' but not when using 'rostopic echo -p /topic_name'.

I want to use the -p option to get a more concise output with 'rostopic echo -p /topic > file.txt' for use with Matlab. (The time it takes for Matlab to parse file.txt is significant, which is why I want the -p option)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-05-01 21:31:43 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

edit flag offensive delete link more
0

answered 2012-05-01 06:48:36 -0600

Dr. Love gravatar image

Answer: I already found a workable solution by changing 'bool' to 'uint8' in my .msg file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-01 06:48:02 -0600

Seen: 250 times

Last updated: May 01 '12