Cannot find the delay when using "rostopic echo -p /topic > ~/log.csv"?

asked 2020-06-29 04:52:31 -0500

Britsk gravatar image

updated 2020-06-29 05:25:30 -0500

gvdhoorn gravatar image

I am using ROS melodic on ubuntu 18.04.

I am writing a topic to a log file for analysis using the command on the title, and the data comes out as this

%time, field.header.seq, field.header.stamp ...
1.57915313445985E+018, 0, 1.57915313445985E+018...
1.57915313445987E+018, 1, 1.57915313445987E+018...
1.57915313446495E+018, 2, 1.57915313446495E+018...

So essentially the publish time and the header time stamp are the same. I expect that these two are different since I got it that way on ubuntu 16.04 with ROS kinetic. But on this ROS melodic they are the same. However when I run "rostopic delay /topic" I still can get the expected delay time.

So is there a way to make the publish time and header timestamp recorded correctly in the log?

Thanks!

edit retag flag offensive close merge delete