Ask Your Question
0

Generating UR5 Robot Package with Moveit Setup Assistant

asked 2019-08-04 13:01:03 -0600

Meric gravatar image

updated 2019-08-04 13:30:43 -0600

Hello I created moveit package with MSA tool, It gave me a edited URDF for UR5 robot and created its own launch and config directory with neccesary files. And after that I would like to simulate this system with RViz and Gazebo. (I know that you dont have to create a Moveit package, there are UR5 Repositories that already did the work, but my case is different).

I run empty.world gazebo with:

roslaunch gazebo_ros empty_world.launch paused:=true use_sim_time:=false gui:=true throttled:=false recording:=false debug:=true

Add up my urdf file in to the system:

rosrun gazebo_ros spawn_model -file place/catkin_ws/src/universal_robot/ur_description/urdf/gaze.urdf -urdf -x 0 -y 0 -z 1 -model ur5

And when I run my launch file with Rviz

<launch>

  <rosparam command="load" file="$(find gaze_demo_moveit_config)/config/joint_names.yaml"/>

  <include file="$(find gaze_demo_moveit_config)/launch/planning_context.launch" >
    <arg name="load_robot_description" value="true" />
  </include>

  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="/use_gui" value="false"/>
    <rosparam param="/source_list">[/joint_states]</rosparam>
  </node>

  <include file="$(find gaze_demo_moveit_config)/launch/move_group.launch">
    <arg name="publish_monitored_planning_scene" value="true" />
  </include>

  <include file="$(find gaze_demo_moveit_config)/launch/moveit_rviz.launch">
    <arg name="config" value="true"/>
  </include>

</launch>

My controller.yaml

controller_list:
  - name: gaze_controller_controller
    action_ns: follow_joint_trajectory
    default: True
    type: FollowJointTrajectory
    joints:
      - wrist_1_joint
      - wrist_2_joint
      - wrist_3_joint

It gives me errors such as:

[ERROR]: Unable to identify any set of controllers that can actuate the specified joints: [ elbow_joint shoulder_lift_joint shoulder_pan_joint wrist_1_joint wrist_2_joint wrist_3_joint ]
[ERROR] : Known controllers and their joints:

[ERROR]: Apparently trajectory initialization failed

And this:

[ERROR]: Action client not connected: gaze_controller_controller/follow_joint_trajectory

I checked my controllers.yaml many times. but everything seem fine. After that I saw some people in answers.ros talks about follow_joint_trajectory topic. when I checked my rostopic I couldnt find that topic? I believe it can be the problem. How can I add that service?

Please help

edit retag flag offensive close merge delete

Comments

1

I don't have time for a full answer right now, but in short: you're not starting any controller. Gazebo only provides a stand-in for your hw, not the control(ler) interface.

Take a look at the ur_gazebo packages and how they load the appropriate ros_control controller(s).

gvdhoorn gravatar imagegvdhoorn ( 2019-08-05 03:05:51 -0600 )edit

Thanks I Added a comment and upvote you

Meric gravatar imageMeric ( 2019-08-06 09:59:59 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-08-05 03:22:01 -0600

pmuthu2s gravatar image

Hello,

I guess you first need to add the joint_trajectory_controller configuration as described in this tutorial. Also, don't forget to get the controllers running! Add them in your launch files.

This should solve your problem I guess.

edit flag offensive delete link more

Comments

Hello yes I found the solution as descriped in this tutorial. I created a package for gazebo launch similar to the tutorial, I made the neccasery launch files for Joint trajectory Controller and finished the tutorial. Now I can control robot with Rviz. However I cannot control it with Moveit Python script.

https://www.youtube.com/watch?v=K09E-...

Meric gravatar imageMeric ( 2019-08-06 09:59:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-08-04 13:01:03 -0600

Seen: 94 times

Last updated: Aug 05 '19