How to ignore "Computed solution is approximate" when planning robotic arm trajectories

asked 2019-07-30 13:03:18 -0500

Mehdi. gravatar image

updated 2019-07-30 13:04:18 -0500

i am trying to get a Panda robot arm (simulated in Gazebo) to move from A to B without flipping the endeffector (eg. while holding a cup of water). I use IKFast as kinematic solver (solve_type: Manipulation1) and OMPL with RRTConnect as planner. It seems that RRTConnects finds a solution but it is rejected because it is approximate. What does that mean? And how to force it to accept it?

[/move_group  INFO 1564509575.128370319, 792.928000000]: RRTConnect: Created 7 states (3 start + 4 goal)
[/move_group  INFO 1564509575.128454908, 792.928000000]: ProblemDefinition: Adding approximate solution from planner RRTConnect
[/move_group  INFO 1564509575.128502497, 792.928000000]: Solution found in 10.021638 seconds
[/move_group  WARN 1564509575.128572929, 792.928000000]: Computed solution is approximate
[/move_group  INFO 1564509575.128616791, 792.928000000]: Unable to solve the planning problem
edit retag flag offensive close merge delete