How to increase clearance for OMPL planner using MoveIt?

asked 2019-07-26 08:34:17 -0500

Sgorba77 gravatar image

Hi, I'm working on Ubuntu 18.04 with ROS melodic. I'm controlling my robot using MoveIt! and the OMPL library. I'm having some problems due to the fact that the OMPL planners are planning trajectories that pass extremely close to the obstacles in the planning scene (it looks like they leave zero clearance). Can anyone help me solve this problem by forcing the planner to increase the clearance? (the minimum allowed distance between trajectories and obstacles)

I'd really appreciate your help. Thank you very much in advance.

edit retag flag offensive close merge delete