Ask Your Question
0

Load TurtleBot3 on Rviz

asked 2019-07-25 10:11:51 -0500

fish24 gravatar image

I'm trying to launch turtlebot3_bringup and turtlebot3_remote on PC with this command line:

$ roslaunch turtlebot3_bringup turtlebot3_remote.launch

The result:

[turtlebot3_remote.launch] is neither a launch file in package [turtlebot3_bringup] nor is [turtlebot3_bringup] a launch file name
The traceback for the exception was written to the log file

What can I do?

Link to the tutorial: http://emanual.robotis.com/docs/en/pl...

ROS: Kinetic

OS: Ubuntu Xenial (16.04)

TurtleBot3 Waffle Pi

edit retag flag offensive close merge delete

Comments

1

Are you sure you are running the command in the host where you have run roscore?

ashutosh08 gravatar imageashutosh08 ( 2019-07-26 04:55:36 -0500 )edit

I have not worked in the workspace. I managed to solve the problem. Thank you for the help!

fish24 gravatar imagefish24 ( 2019-07-26 11:54:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-26 04:55:17 -0500

fish24 gravatar image

I solved it. Before opening a new terminal to write: $ roslaunch turtlebot3_bringup turtlebot3_remote.launch , go in your workspace and add source, in my case:

$ cd ~/catkin_ws
$ source devel/setup.bash
edit flag offensive delete link more

Comments

so please mark the question as solved

duck-development gravatar imageduck-development ( 2019-07-26 16:50:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-07-25 10:11:51 -0500

Seen: 25 times

Last updated: Jul 26