ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

pcd file failed

asked 2019-07-25 10:05:16 -0500

hoang khac gravatar image

updated 2019-07-26 18:29:46 -0500

jayess gravatar image

I have been trying to use Autoware to map a large area ( bag file of 5.3 GB). After the mapping has been done, i output the pcd map according to

After i output the map, when i tried using the .pcd file in the map tab, on the console it said "failed "Path_to_pcd_file"" and only map a part of the map that were supposed to be created. Has anybody had this problem before and if so how do i fix it? I suspect that it is because the output map is quite large (253.MB), as i was trying to map with smaller maps before and autoware worked fine.

Thanks in advance


For the pcd file, you can find it here I am using:

  • autoware 1.10.0
  • Ubuntu 16.04

I installed ros from source, following the instruction in this link and i am not using docker.

edit retag flag offensive close merge delete


Would you please share a screenshot of the console showing the error? And if possible, please share your .pcd file.

Yamato Ando gravatar image Yamato Ando  ( 2019-07-26 06:52:24 -0500 )edit

We also need to know which version of Autoware you are using, what version of Ubuntu, how you installed ROS (source or from apt), and whether or not you are using Docker.

Josh Whitley gravatar image Josh Whitley  ( 2019-07-26 08:48:47 -0500 )edit

Hi, Thank you all for answering to my question. I am very new to this so excuse me for the newbie's mistake For the pcd file, you can find it on I am using autoware 1.10.0 on Ubuntu 16.04. I installed ros from source, following the instruction in this link and i am not using docker. Unfortunately, i am not with my laptop at the moment and can not provide the console of the error. I really do appreciate if anybody has any advices.

hoang khac gravatar image hoang khac  ( 2019-07-26 11:11:17 -0500 )edit

@hoang khac I've edited your question to include the information from your comment so that it's easier to find

jayess gravatar image jayess  ( 2019-07-26 18:30:19 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-07-26 17:53:43 -0500

Yamato Ando gravatar image

Thank you for sharing PCD.

It seems that the number of point clouds written in the header of the file is different. Please open autowre-190725.pcd with an editor and rewrite WIDTH and POINTS from 35006911 to 8080162.

edit flag offensive delete link more


Thank you very much i will try that once i get back

hoang khac gravatar image hoang khac  ( 2019-07-27 05:05:54 -0500 )edit

Thank you so much. It now has worked output the correct answers.

hoang khac gravatar image hoang khac  ( 2019-07-31 08:51:40 -0500 )edit

Question Tools


Asked: 2019-07-25 10:04:46 -0500

Seen: 265 times

Last updated: Jul 26 '19