Ask Your Question
0

Time stamps in header message is always 0

asked 2019-06-26 16:31:03 -0500

rRawCWwTKVM gravatar image

Using ROS Kinetic on Ubuntu linux. For some reason, the time stamps (sec, and nsec values) in the standard header msg always come out as 0.

Does something have to be 'enabled' somewhere?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-06-26 16:33:43 -0500

ahendrix gravatar image

ROS does not set the header timestamps automatically; the code that publishes the message has to set the timestamp.

edit flag offensive delete link more

Comments

Ah! haha. Excellent. I thought it was automatically

rRawCWwTKVM gravatar imagerRawCWwTKVM ( 2019-06-26 16:40:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-06-26 16:31:03 -0500

Seen: 26 times

Last updated: Jun 26