Unable to load the manifest for package std_msgs

asked 2019-06-24 04:06:21 -0500

I am running roslaunch rosbridge_server rosbridge_websocket.launch , but it is useless to send any message through the browser, and the browser does not receive the topic of ros.

Error is as follows:

[ERROR] [1561364818.360155]: [Client 0] [id: subscribe:/listener :1] subscribe: Unable to load the manifest for package std_msgs. Caused by: line:
yaml https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml osx
unsupported pickle protocol: 4

[ERROR] [1561364913.851892]: [Client 0] [id: advertise:/turtle1/cmd_vel:2] advertise: Unable to load the manifest for package geometry_msgs. Caused by: line:
yaml https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml osx
unsupported pickle protocol: 4

I don't know why, I uninstalled and reinstalled and it didn't work.

edit retag flag offensive close merge delete