ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Cannot install packages (trying to resolve: could not find pkg cfg file provided by X)

asked 2019-06-13 15:27:50 -0500

Gi99 gravatar image

updated 2019-06-14 02:56:26 -0500

gvdhoorn gravatar image

Hello, I am runnig ROS kinetic on an Uuntu 16.04 and I downloaded a repository from github and pasted it into the src directory of my catkin_ws, but whenever I run "catkin_make" I always get this error:

-- Could not find the required component 'controller_manager'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by
  "controller_manager" with any of the following names:


  Add the installation prefix of "controller_manager" to CMAKE_PREFIX_PATH or
  set "controller_manager_DIR" to a directory containing one of the above
  files.  If "controller_manager" provides a separate development package or
  SDK, be sure it has been installed.

I tried downloading the controller_manager package by downloading ros_control with the following command from

sudo apt-get install ros-kinetic-ros-control ros-kinetic-ros-controllers

However, when I try this command, I'm getting these errors:

Err:1 xenial/main amd64 ros-kinetic-hardware-interface amd64 0.13.3-0xenial-20190320-132757-0800
  404  Not Found [IP: 80]
Err:2 xenial/main amd64 ros-kinetic-controller-interface amd64 0.13.3-0xenial-20190320-133652-0800
  404  Not Found [IP: 80]
Err:3 xenial/main amd64 ros-kinetic-realtime-tools amd64 1.11.1-0xenial-20190320-130942-0800
  404  Not Found [IP: 80]
Err:4 xenial/main amd64 ros-kinetic-diff-drive-controller amd64 0.13.5-0xenial-20190320-171041-0800
  404  Not Found [IP: 80]
Err:5 xenial/main amd64 ros-kinetic-ackermann-steering-controller amd64 0.13.5-0xenial-20190320-175427-0800
  404  Not Found [IP: 80]
Err:6 xenial/main amd64 ros-kinetic-combined-robot-hw amd64 0.13.3-0xenial-20190320-133622-0800
  404  Not Found [IP: 80]
Err:7 xenial/main amd64 ros-kinetic-controller-manager-msgs amd64 0.13.3-0xenial-20180824-100448-0800
  404  Not Found [IP: 80]
Err:8 xenial/main amd64 ros-kinetic-controller-manager amd64 0.13.3-0xenial-20190320-134400-0800
  404  Not Found [IP: 80]
Err:9 xenial/main amd64 ros-kinetic-controller-manager-tests amd64 0.13.3-0xenial-20190320-153143-0800
  404  Not Found [IP: 80]
Err:10 xenial/main amd64 ros-kinetic-combined-robot-hw-tests amd64 0.13.3-0xenial-20190320-154237-0800
  404  Not Found [IP: 80]
Err:11 xenial/main amd64 ros-kinetic-control-toolbox amd64 1.17.0-0xenial-20190320-143943-0800
  404  Not Found [IP: 80]
Err:12 xenial/main amd64 ros-kinetic-forward-command-controller amd64 0.13.5-0xenial-20190320-140150-0800
  404  Not Found [IP: 80]
Err:13 xenial/main amd64 ros-kinetic-effort-controllers amd64 0.13.5-0xenial-20190320-144804-0800
  404  Not Found [IP: 80]
Err:14 http ...
edit retag flag offensive close merge delete


Have you tried doing what it says and running apt-get update? Have you updated your keys for the package repositories?

Geoff gravatar image Geoff  ( 2019-06-13 18:30:17 -0500 )edit

I'm having a similar issue anbd --fix missing doens't work either

tomsepe gravatar image tomsepe  ( 2019-06-16 00:17:35 -0500 )edit

I get this:

Get:10 xenial-updates InRelease [109 kB]
Err:6 xenial InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F42ED6FBAB17C654 Hit:11 xenial-backports InRelease
Fetched 230 kB in 1s (203 kB/s)
Reading package lists... Done W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F42ED6FBAB17C654 W: Failed to fetch The following signatures couldn't be verified because the p

tomsepe gravatar image tomsepe  ( 2019-06-16 00:17:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-06-14 02:06:57 -0500

gvdhoorn gravatar image

updated 2019-06-14 02:55:43 -0500

As @Geoff hints at, this is most likely caused by the key switch.

Refer to #q325039.

I downloaded a repository from github and pasted it into the src directory of my catkin_ws, but whenever I run "catkin_make" I always get this error:

Please note that just cloning a single repository into your workspace will not work in most cases. You'll have to make sure to have installed all required dependencies.

See the answer to #q252478 for an example workflow.

edit flag offensive delete link more


I tried what @Geoff said and it worked! I updated my keys and used sudo apt-get update. The problem with #q252478 workflow is that I am following a script and when I use git clone (...) it asks for an username and a password that I don't have. But if I had the password and username, I think it would've worked. Thanks a lot!

Gi99 gravatar image Gi99  ( 2019-06-17 12:01:54 -0500 )edit

Question Tools

1 follower


Asked: 2019-06-13 15:27:50 -0500

Seen: 1,711 times

Last updated: Jun 14 '19