ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rmw implementation error running ros2 examples

asked 2019-05-22 08:17:08 -0500

RodBelaFarin gravatar image

I tried to run the basic rclcpp examples from the colcon tutorial

after installing ROS2 Crystal Clemmys regarding to this instructions on my Ubuntu 18.04 system.

running the subscriber example

ros2 run examples_rclcpp_minimal_subscriber subscriber_member_function

i end up in an error:

terminate called after throwing an instance of 'rclcpp::exceptions::RCLError'
  what():  failed to initialized rcl init options: failed to load shared library of rmw implementation. Exception: Cannot load library: /opt/ros/crystal/lib/ undefined symbol: _ZTVN8eprosima8fastrtps27DataRepresentationQosPolicyE, at /tmp/binarydeb/ros-crystal-rmw-implementation-0.6.1/src/functions.cpp:136, at /tmp/binarydeb/ros-crystal-rcl-0.6.5/src/rcl/init_options.c:55

any hints on how to solve this?

edit retag flag offensive close merge delete


same thing happening to me too today. I left some terminals open from yesterday and running things there was ok. as soon as i sourced a new environment i got the same error.

pantphotiou gravatar image pantphotiou  ( 2019-05-23 13:53:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-06-11 04:18:26 -0500

PratNag gravatar image

I had the same problem but on Windows after installing Ros2 from binaries. Building ROS2 from source solved the problem for me.

Other solution I saw was to install OpenSplice and set the rmw implemenation to that.\

edit flag offensive delete link more

Question Tools



Asked: 2019-05-22 08:17:08 -0500

Seen: 914 times

Last updated: Jun 11 '19