Ask Your Question
2

Can't find my command "rosinstall"

asked 2012-04-21 21:45:50 -0500

bcddivad gravatar image

updated 2012-04-22 16:11:14 -0500

I installed ros-electric on my ubuntu10.04 and tried to install the 3D package by writing a t.rosintall file as follow

  - svn:
      uri: https://code.ros.org/svn/wg-ros-pkg/branches/trunk_diamondback/sandbox/3d_navigation/
      local-name: stacks/3d_navigation
  - svn:
      uri: https://alufr-ros-pkg.googlecode.com/svn/trunk/octomap_mapping
      local-name: stacks/octomap_mapping
  - svn:
      uri: https://code.ros.org/svn/wg-ros-pkg/stacks/motion_planning_common/branches/arm_navigation_metrics
      local-name: stacks/motion_planning_common

However when I tried to install the package by the command

  rosinstall . /opt/ros/electric/ ./t.rosinstall

It showed:

  bcddivad@bcddivad-laptop:~/code/ros$ rosinstall ./opt/ros/electric/ ./t.rosinstall
  rosinstall: command not found
  bcddivad@bcddivad-laptop:~/code/ros$

Then I tried sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install ros-electric-*

but still in vein. Can anyone please help me?

Thanks to @Dan Lazewatsky

And for those who haven't installed pip , please view here

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
5

answered 2012-04-22 04:31:42 -0500

rosinstall is not installed as part of the debian packages. You can install it with pip as follows

sudo pip install -U rosinstall
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-04-21 21:45:50 -0500

Seen: 770 times

Last updated: Apr 22 '12