Ask Your Question
0

Malformed entry Ubu

asked 2019-05-08 23:31:30 -0600

jrock gravatar image

I have searched these forums and found them helpful in the past, however, I can't seem to find a viable option for my problem. When I try to apt-get update (Ubuntu bionic 18), I get the following:

E: Malformed line 1 in source list /etc/apt/sources.list.d/rehinkdb.list (type)
E: Malformed entry 1 in list file /etc/apt/sources.list.d/ros-latest.list (Component)

E: The list of sources could not be read.

I have tried lsb-release with no success. I appreciate any help from your expertise. Thank you.

edit retag flag offensive close merge delete

Comments

Is this only happen when installing ROS?

achmad_fathoni gravatar imageachmad_fathoni ( 2019-05-09 01:48:51 -0600 )edit
1

What is the output of:

cat /etc/apt/sources.list.d/ros-latest.list

I have tried lsb-release with no success.

What do you mean exactly by this? Does lsb_release -c not output anything, or do you not have the program installed?

if the latter: that could be the cause of those two files containing malformed entries (as some information is missing that lsb_release would provide).

gvdhoorn gravatar imagegvdhoorn ( 2019-05-09 05:08:30 -0600 )edit

gvdhoorn the output is

deb http:packages.ros.org/ros/ubuntu main

lsb_release -c outputs

Codename:       bionic

Thank you

jrock gravatar imagejrock ( 2019-05-09 18:19:28 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-09 18:33:37 -0600

tfoote gravatar image

Your apt sources.list content is malformed, you are missing the distribution name

Here's a reference for the file format: https://wiki.debian.org/SourcesList

It should be of the form deb http://site.example.com/debian distribution component1 component2 component3

So if you change it to

deb http://packages.ros.org/ros/ubuntu bionic main

It should work.

Based on the above error message I would guess that you have the same problem with your rethinkdb.list file too

edit flag offensive delete link more

Comments

tfoote did I download a corrupt package on the upgrade? Here is what I got:

deb http://packages.ros.org/ros/ubuntu bionic main

Command 'deb' not found, did you mean:



 command 'den' from snap den (1.2.0-0)
  command 'dub' from snap dub (1.14.0)
  command 'debc' from deb devscripts
  command 'derb' from deb icu-devtools
  command 'edb' from deb edb-debugger
  command 'dex' from deb dex
  command 'dep' from deb go-dep
  command 'dub' from deb dub
  command 'dab' from deb bsdgames
  command 'debi' from deb devscripts
  command 'xdeb' from deb xdeb
  command 'deb3' from deb quilt

See 'snap info <snapname>' for additional versions

jrock gravatar imagejrock ( 2019-05-09 22:29:55 -0600 )edit

deb is not a command. It's the first word that should appear on the line in the .list files.

gvdhoorn gravatar imagegvdhoorn ( 2019-05-10 00:25:29 -0600 )edit

Thank you. That solved the problem.

jrock gravatar imagejrock ( 2019-05-11 17:55:57 -0600 )edit

Please use the checkbox at left to accept the answer so people know your question is solved.

tfoote gravatar imagetfoote ( 2019-05-11 19:19:50 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-08 23:31:30 -0600

Seen: 56 times

Last updated: May 09