Error during ROS2 install on raspberry pi 3 - Ubuntu server

asked 2019-03-29 02:44:33 -0600

Nhey gravatar image

updated 2019-04-06 18:36:33 -0600

jayess gravatar image

Hello everyone !

I got a problem while installing ROS2 on my raspberry pi 3 B ubuntu 18.04 server. I follow this tuto. All command line passed well and when I run

sudo apt install ros-crystal-desktop

Unable to locate package ros-crystal-desktop

I tried install from source too, following this tuto. All is fine, I don’t install optional DDS implementation and when I

run colcon build --symlink-install

/home/ubuntu/ros2_ws/src/ament/ament_index/ament_index_cpp/test/utest.cpp:268:1 internal compiler error: Segmentation fault

If someone can help me on one this these problem, so I can run ROS2 on my Raspberry I’ll be very happy !

Best regards ROS community !

edit retag flag offensive close merge delete

Comments

Did you install the apt sources as specified in the tuto ? The debian packages only exist for arm64. If your Pi has its OS on armv7l (you can check with uname -a), you have to install by building the sources.

William Bulle gravatar image William Bulle  ( 2019-03-29 07:04:18 -0600 )edit

Hi.

uname -a send me the following answer : Linux ubuntu 4.15.0-1032-raspi2 #34-Ubuntu SMP PREEMPT <date hour=""> UTC 20 19 armv7l armv7l armv7l GNU/Linux

Yes I've down all previous errors without error. You're right, my Pi is on armv7l, but, like I said, I tried from building source and I got an error during colcon build running : "Internal compiler error".

Nhey gravatar image Nhey  ( 2019-03-29 07:35:05 -0600 )edit
2

You might want to try to:

  1. limit compilation to use a single instance of gcc at a time (ie: single job)
  2. enabling swap

an RPi doesn't have a lot of memory, and compiling complex software like ROS 2 can easily exhaust what it does have.

gvdhoorn gravatar image gvdhoorn  ( 2019-03-29 07:51:58 -0600 )edit