Ask Your Question
1

Bug in ROS_INFO_STREAM?

asked 2012-04-13 11:34:08 -0500

bkx gravatar image

updated 2014-01-28 17:11:58 -0500

ngrennan gravatar image

I have a stringstream that I'm using to store some debug information. Every so often, I try to print it out. I have found that

string s = ss.str();
ROS_INFO_STREAM(s);

works just as expected, the contents of ss are displayed in a message. But an operation that I feel should be identical,

ROS_INFO_STREAM( (ss.str()) );

results in nothing at all being displayed, except of course the usual ROS_INFO header "[ INFO]..."

Any ideas on why this could be?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-04-16 01:14:00 -0500

Lorenz gravatar image

Probably a bug in the implementation of the macro ROS_INFO_STREAM. Bug reports should go to the corresponding bug tracker, for rosconsole use the trac here.

edit flag offensive delete link more
0

answered 2012-07-04 05:38:41 -0500

dornhege gravatar image

updated 2012-07-06 00:23:59 -0500

I ran into the same thing.

As I didn't see a ticket, I opened a new one.

... and it's been fixed within one day! Intermediate solution until that is released: Just don't name the variable "ss".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-13 11:34:08 -0500

Seen: 851 times

Last updated: Jul 06 '12