How to let eef reach the goal of path planning, not flange ?

asked 2019-02-21 07:17:57 -0600

A_YIng gravatar image

updated 2019-02-21 07:21:17 -0600

Hello, I'm a beginner of ROS-I and use Ubuntu 16.04 with Kinetic version.

I follow this tutorials to implement Motion Planning with my YASKAWA MH5 model.

After that, I tried Descartes Path Planning and it's working fine with mine.

However, I want the robot to pick some objects, but I found the robot uses the position of flange(link_t) to be the goal of path planning, not eef.

Actually, I add a gripper (design by myself) to my URDF file and setup it in MoveIt! Setup Assistant(another Planning Groups, Label End Effectors), but It still doesn't have any change. image description image description

Does it have any possible way to move robot arm to goal position with eef ?

Here is my robot model: image description

and launch file message:

[ INFO] [1550753805.151307306]: Loading robot model 'motoman_mh5'...
[ INFO] [1550753805.196031369]: Loading robot model 'motoman_mh5'...
[ INFO] [1550753805.279385319]: Starting scene monitor
[ INFO] [1550753805.283462846]: Listening to '/move_group/monitored_planning_scene'
[ INFO] [1550753805.722741551]: Constructing new MoveGroup connection for group 'arm' in namespace ''
[ INFO] [1550753806.946713982]: Ready to take commands for planning group arm.
[ INFO] [1550753806.946780755]: Looking around: no
[ INFO] [1550753806.946808706]: Replanning: no
[ WARN] [1550753806.969202339]: Interactive marker 'EE:goal_link_t' contains unnormalized quaternions. This warning will only be output once but may be true for others; enable DEBUG messages for ros.rviz.quaternions to see more details.
edit retag flag offensive close merge delete