Unable to locate package libgl1-mesa-dev-lts-trusty

asked 2019-02-20 11:26:24 -0500

kkulkarn gravatar image

I'm following instructions on how to install ROS indigo ( http://wiki.ros.org/indigo/Installati... ) and I'm getting an error while trying to install libgl1-mesa-dev-lts-trusty. The error is "Unable to locate package libgl1-mesa-dev-lts-trusty' I did include a few suggested mirror sites in the source.list. Apparently this is to fix the dependency issues before installing ROS. My hardware is i386 based Dell desktop running Ubuntu 14.04 I searched for answers although there are solutions for Ubuntu 16.04 and 14.04.02 but not for 14.04. Can I just go ahead with installing ROS ignoring this error?

edit retag flag offensive close merge delete

Comments

this is weird. The package is listed at ubuntu website. You sure you did sudo apt-update? I can try running in docker if this doesn't work

kolya_rage gravatar imagekolya_rage ( 2019-02-21 02:53:13 -0500 )edit

Yes, indeed. Also, I came to know that the processor I have on my desktop is 64 bit Intel Xeon. I miss-stated as i386 based in my question.

kkulkarn gravatar imagekkulkarn ( 2019-02-21 04:49:25 -0500 )edit

I tried docker container with ubuntu 14.04. Installation went just fine. apt update apt install libgl1-mesa-dev-lts-trusty It can happen if your ubuntu is so old, so you have too old keys for repositories. If you do apt update - it should say so.

kolya_rage gravatar imagekolya_rage ( 2019-02-21 05:15:10 -0500 )edit

apt update was successful. Hut still I get the following;

$ sudo apt-get install libgl1-mesa-dev-lts-trusty Reading package lists... Done Building dependency tree
Reading state information... Done E: Unable to locate package libgl1-mesa-dev-lts-trusty

kkulkarn gravatar imagekkulkarn ( 2019-02-21 08:30:47 -0500 )edit

I tried uninstalling all gazebo versions greater than 2. Tried again, but did not work. Got the same error - unable to locate package lbgl1----- I went ahead and tried installing ros-indigo-desktop-full. The following dependency errors result; desktop, perception, urdf-tutorials, & viz :(

kkulkarn gravatar imagekkulkarn ( 2019-02-21 14:24:10 -0500 )edit

well, I suggest either updating to ubuntu 16 or working through docker which is the best thing ever if you have different projects with different deps. You can run GUI though docker as if you ran it natively.

kolya_rage gravatar imagekolya_rage ( 2019-02-21 14:28:02 -0500 )edit

Got it. Thanks.

kkulkarn gravatar imagekkulkarn ( 2019-02-22 11:32:14 -0500 )edit