ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

No interactive markers displayed whilst following moveit! tutorial ROS Kinetic

asked 2019-02-15 09:59:07 -0500

Burarara gravatar image

updated 2019-02-22 12:45:14 -0500

jayess gravatar image

I am new to using rviz and moveit and currently working through the following tutorials on ROS Kinetic:


I completed the first link, moving onto the second link (quickstart in rviz) and completing steps 1 and 2 I find that the interactive markers are not displaying. I am unsure where the errors lie here considering I have followed the instructions perfectly.

When examining the terminal which launches moveit tutorial I see that I have a warning. I'm not sure how relevant it will be but I have included it anyway:

[ WARN] [1550244405.694068338]: Unable to update multi-DOF joint 'virtual_joint': TF has no common time between '/world' and 'panda_link0':

Further searching around I have found that this issue may have popped up before:

However the link to the discussion is something beyond me and it doesn't seem to appear to be instructions to fix it. Unsure where to go from here and would appreciate any suggestions to fixes. Please let me know if more information is required from logs etc.

edit retag flag offensive close merge delete


Having the same issue

benb35 gravatar image benb35  ( 2019-02-20 22:04:08 -0500 )edit

I have the same problem, please let me know if someone finds a solution!

I get an also an info, that "Stereo is NOT SUPPORTED" because "OpenGl version: 3 (GLSL 1.3)". This might be because I have got a machine with an Intel on board graphics...

Do you also get this? Might this be a problem?

kevin29 gravatar image kevin29  ( 2019-02-22 02:19:45 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted

answered 2019-02-22 10:15:35 -0500

Burarara gravatar image

Although I did not seem to find a permanent solution to the downloaded demo not displaying interactive markers, I did however find an alternative way to work around it. Simply following the instructions of the next step in the tutorials, the setup assistant tutorial ( ), will ask you to delete the panda demo folder and you will replace it yourself with a new panda which you create yourself. After this I found that interactive markers were now displaying on the new panda so I could go back and explore the previous tutorial.

I don't have an ideal fix to this, nor do I have a concrete answer as to why the demo panda does not display it (I suspect it to be linked with the end effector of the panda not being properly configured) but hopefully this will allow anyone working with moveit for the first time to continue with the tutorials.

edit flag offensive delete link more


Having the same problem,but thank you for the answer since the assistant can repair it.

Conan gravatar image Conan  ( 2019-03-03 01:44:22 -0500 )edit

This way worked for me too.

rebecatourinho gravatar image rebecatourinho  ( 2019-04-04 08:24:39 -0500 )edit

answered 2019-02-26 21:04:16 -0500

yakunix gravatar image

This happened because the recent update of panda_moveit_config package. Try to reverse to 03bb4 commit and recompile the package then restart the launch file, the markers will appear.

edit flag offensive delete link more


Thanks. This works for me! (on ROS Melodic)

an_nguyen gravatar image an_nguyen  ( 2019-03-07 12:24:57 -0500 )edit

how can i do that, i dont understand .

tien dang gravatar image tien dang  ( 2019-03-13 10:59:23 -0500 )edit

cd to panda_moveit_config and git checkout 03bb4 :)))

hoang_chu gravatar image hoang_chu  ( 2019-04-30 12:09:21 -0500 )edit

Encountered the same "No Interactive markers" problem on ROS Kinetic Branch: kinetic-devel Feb 9, 2019 commit 142fb79. Solved the same way by reverse to 3a1e58d Nov. 9, 2018 with git checkout, recompile & restart launch, the markers appear following the Moveit! Tutorial procedure.

RobotRoss gravatar image RobotRoss  ( 2019-05-02 16:39:33 -0500 )edit

Please, I don't understand. Can you be explicit? I couldn't find the commit on Github. Please help me understand how to fix the interactive marker problem on ROS Kinetic. Thank you @Red24Dog, @an_nguyen, @hoang_chu and @yakunix

sosalau gravatar image sosalau  ( 2020-01-24 19:22:53 -0500 )edit

@sosalau the commit id starts with "03bb4". Just git clone the repo and git checkout 03bb4 then you will get to it.

an_nguyen gravatar image an_nguyen  ( 2020-01-24 19:58:56 -0500 )edit

Thank you @an_nguyen. It works, I can now see the interactive markers.

sosalau gravatar image sosalau  ( 2020-01-25 09:14:25 -0500 )edit

answered 2019-02-22 09:42:46 -0500

kevin29 gravatar image

Looks like the problem is solved on my machine. I have now uninstalled all moveIt packages that I had installed in the past according to: .

Because I had also installed "libfranka" and "franka_ros" ( ), I have also uninstalled it to have a clean system.

After this, I tried to reinstall everything, but this time not by building "libfranka" and "franka_ros" from source, but rather by installing it from ROS repositories ( ). After the installation of this two packages, the problem was solved, and I didnt need to install further moveIt packages from .

Hope this helps someone else also..

edit flag offensive delete link more


Thank you for this, although I did find a way to work around it I will keep this in mind should an issue with the interactive marker reappear in the future.

Burarara gravatar image Burarara  ( 2019-02-22 10:17:33 -0500 )edit

answered 2021-02-01 12:38:57 -0500

h.ayoobi gravatar image

Hello, I had the same issue that the interactive marker of the end effector for the UR5 robotic arm was not visible. Moreover, I have seen a warning as follows:

[ WARN] Skipping virtual joint 'fixed_base' because its child frame 'pedestal_base_link' does not match the URDF frame 'world'

I think this warning was not very important for my case. After trying different solutions recommended on this page, I have found a simple solution that worked for me. I decided to post it here in case anyone has the same issue as me.

For my case, the problem was the interactive marker size in rviz (I don't know why it was zero by default). By just setting its size (motion planning > planning request > Interactive Marker Size = 0.2) the problem is solved for me.

I hope that this solution saves someone else's time.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2019-02-15 09:49:07 -0500

Seen: 1,381 times

Last updated: Feb 01 '21