Ask Your Question
0

launchfile remote machines: Temporary failures

asked 2019-02-14 10:48:08 -0600

krl101 gravatar image

updated 2019-02-15 04:04:03 -0600

Hi community!

Setup:

  • Ubuntu 16 with ROS-kinetic, LAN, static ip
  • Raspberry Pi 2 with ROS-kinetic, LAN, static ip

Each one is with the beginner_tutorials ready to rock... It works if i start roscore and talker/listener node on the corresponding machine. As minimum lanuchfile, i tried to start the beginners_tutorial/talker on my Pi from PC with:

<launch>
      <machine name="TCG" address="TCG" user="user" env-loader="/home/pi/catkin_ws/devel/env.sh"/>
      <node machine="TCG" pkg="beginner_tutorials" name="talker" type="talker"/>
</launch>

Result:

......
remote[TCG4-1008-0]: ssh connection created
SUMMARY
========
PARAMETERS
* /rosdistro: kinetic
* /rosversion: 1.12.14

MACHINES
* TCG

NODES
/talkerTCG4 (beginner_tutorials/talker)

auto-starting new master
process[master]: started with pid [13173]
ROS_MASTER_URI=http://10.42.0.1:11311
setting /run_id to 89e119632c594e
process[rosout-1]: started with pid [13186]
started core service [/rosout]
error launching on [TCG-0, uri http://TCG:42313/]: Temporary failure in name resolution
Launch of the following nodes most likely failed: beginner_tutorials/talker
^C[TCG] killing on exit
remote[TCG-0]: unable to contact [TCG] to shutdown remote processes!
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I followed Network Setup, and every thing works, pinging, ssh, ROS_MASTER_URI, ROS_IP, and so on.

Question From Temporary failure in name resolution there is a problem with the names, have i mixed-up some name (etc/hosts, hostname, launch-file parameter)

I am grateful for every advice!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-12-02 02:33:56 -0600

tfe gravatar image

I just ran into the same problem, and I solved this problem according to this ros wiki page

and configure the /etc/hosts file as follows

IPAddress Hostname
192.168.1.10 localhost

Note that hostname/ip may vary according to your devices, and the ros wiki suggests to set Alias, while my /etc/hosts file has no Alias column, so I just skip them.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-02-14 10:48:08 -0600

Seen: 122 times

Last updated: Feb 15 '19