Gazebo for two launch files (turtlebot_world.launch and gmapping_demo.launch) cannot simultaneously run?

asked 2019-02-13 16:54:27 -0500

ahumay gravatar image

Before this gets marked as a duplicate of , I tried everything in that question and the comments only allow me to post so much text. I am just trying to make a map and navigate it in the Gazebo. I am running Ubuntu 15.10 and ROS Kinetic. I run these in separate terminal windows:

roslaunch turtlebot_gazebo turtlebot_world.launch

roslaunch turtlebot_gazebo gmapping_demo.launch

roslaunch turtlebot_rviz_launchers view_navigation.launch

roslaunch kobuki_keyop keyop.launch

But I my kobuki_keyop does not work, giving me:

[ WARN] [1550005269.894992827]: KeyOp: could not connect, trying again after 500ms...
[ERROR] [1550005270.400225747]: KeyOp: could not connect.
[ERROR] [1550005270.400604286]: KeyOp: check remappings for enable/disable topics).

I then check the roslaunch turtlebot_gazebo turtlebot_world.launch terminal window, and see the following error:

[gazebo-1] process has died [pid 5190, exit code 134, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /opt/ros/kinetic/share/turtlebot_gazebo/worlds/ __name:=gazebo __log:=/home/tony15/.ros/log/534c6c66-2ef1-11e9-854a-080027d85737/gazebo-1.log].
log file: /home/tony15/.ros/log/534c6c66-2ef1-11e9-854a-080027d85737/gazebo-1*.log

Upon further inspection, it seems that if I roslaunch turtlebot_gazebo turtlebot_world.launch, then as soon as I roslaunch turtlebot_gazebo gmapping_demo.launch, the turtlebot_world.launch receives the previous error (which then explains why the kobuki_keyop doesn't work).

turtlebot_world.launch works completely fine on it's own.

turtlebot_world.launch and kobuki_keyop work fine when both running.

Does anyone know why my turtlebot_world.launch and gmapping_demo.launch / turtlebot_rviz_launchers can't seem to run at the same time?

edit retag flag offensive close merge delete