Ask Your Question
0

rviz error. segmentation fault (core dumped)

asked 2019-02-12 10:39:53 -0500

jrwong236 gravatar image

updated 2019-02-12 16:13:42 -0500

trying to run step 5 in introduction to tf tutorial http://wiki.ros.org/tf/Tutorials/Intr... rviz doesn't open and i get the following error

IBUS-WARNING **: Unable to connect to ibus: could not connect: connection refused. Segmentation fault (core dumped)

what isn't working?

UPDATE I deleted the ibus folder from .config/ and now i don't get an ibus warning BUT rviz still doesn't open

    ** (rviz:6145): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ZMaEcTk69B: Connection refused
[ INFO] [1550009580.667843143]: rviz version 1.12.16
[ INFO] [1550009580.667895937]: compiled against Qt version 5.5.1
[ INFO] [1550009580.667912081]: compiled against OGRE version 1.9.0 (Ghadamon)
[ INFO] [1550009580.814606867]: Stereo is NOT SUPPORTED
[ INFO] [1550009580.814686668]: OpenGl version: 3 (GLSL 1.3).
Segmentation fault (core dumped)

it fails to open. why?

edit retag flag offensive close merge delete

Comments

kolya_rage gravatar image kolya_rage  ( 2019-02-12 16:06:41 -0500 )edit

I'm not having a problem with the ibus warning anymore but now I just get a warning about accessibility bus. what is that?

jrwong236 gravatar image jrwong236  ( 2019-02-12 16:16:03 -0500 )edit

RViz issues are typically caused by missing GPU drivers, faulty GPU drivers, or running in a virtual machine (or under WSL on Windows 10).

What sort of hardware do you have?

gvdhoorn gravatar image gvdhoorn  ( 2019-02-13 01:54:10 -0500 )edit

I'm using Xubuntu 16.04. I have a laptop that i dual booted with Windows and Xubuntu. Running Rviz through Xubuntu of course. Anyway to update the GPU? It has worked previously with my laptop but haven't gotten it to work this time around.

jrwong236 gravatar image jrwong236  ( 2019-02-19 16:18:08 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-02-19 16:42:12 -0500

jrwong236 gravatar image

updated 2019-02-19 16:43:16 -0500

Found Solution: https://github.com/ros-visualization/...

the solution was update the graphics library: http://ubuntuhandbook.org/index.php/2...

Now my rviz program runs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-12 10:39:53 -0500

Seen: 2,338 times

Last updated: Feb 19 '19