unable to start gazebo ros controller

asked 2019-02-05 15:15:36 -0600

ahmed samir gravatar image

updated 2019-02-06 02:42:36 -0600

gvdhoorn gravatar image

i am new to ros, and i was trying to control my custom made robot on gazebo first i added the transmission tag for all the joints ,i also added the gazebo_ros_control plug-in in the urdf file and finally configured the controllers in the config.ymal file and created the launch file to start the control_spawner and the joint_state_publisher nodes and load the joint controllers configuration but i keep getting the following error

load_parameters: unable to set parameters (last param was [/pid/d=10.0]): cannot marshal None unless allow_none is enabled

even tho i added the PID values in for all the joints in the config file anyone knows how can i start to debug this?.. thanks in advance

edit retag flag offensive close merge delete

Comments

all the joints are revolute with specified effort and velocity and limits i also tried to change the pid values but still got the same error with different d values

ahmed samir gravatar image ahmed samir  ( 2019-02-05 15:26:10 -0600 )edit

You'll probably have to show us your launch file, as it looks like the plugin is not finding your parameters.

How are you loading them?

gvdhoorn gravatar image gvdhoorn  ( 2019-02-06 02:43:03 -0600 )edit