Robotic arm not moving in motion planning

asked 2019-02-02 17:59:42 -0500

ahmed samir gravatar image

updated 2019-02-03 09:35:17 -0500

gvdhoorn gravatar image

Hi guys so i was working on a project to move a robotic arm using rviz, first i made the design on solidworks, used SW2URDF to get the URDF file, the URDF code is too long to post here but basically i checked that the joint limits are correct first i launched the display.launch file into rviz, played with it a little using the joint state sliders and it was moving fine i wanted to move on to motion planning so i ran the file through MoveIt setup assistant following this tutorial then i launched the demo.launch through rviz, made sure i am using my robot base as fixed frame the problem is that the robot isn't moving with the interactive markers like the panda robot in the tutorial did i can't move the robot at all, so i can't perform motion planning i tried to bypass that by generating random goal and start states in the planning tab but ofc the planing failed

i also noticed these 2 warnings in the command line:

[ WARN] [1549150437.741202943]: Interactive marker 'EE:goal_Gripper' contains unnormalized quaternions. This warning will only be output once but may be true for others; enable DEBUG messages for ros.rviz.quaternions to see more details.

[ WARN] [1549150436.699550818]: The root link base_link has an inertia specified in the URDF, but KDL does not support a root link with an inertia.  As a workaround, you can add an extra dummy link to your URDF.

can anyone guide me to what might be the issue here?.. thanks in advance

edit retag flag offensive close merge delete


can you solve the problem I have same problem now pls share if you know something

nguyentuMTA gravatar image nguyentuMTA  ( 2019-04-01 19:56:46 -0500 )edit