ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

IKFast testik fails with 0% success rate

asked 2019-01-19 17:06:50 -0500

robonoob gravatar image

updated 2019-01-19 20:42:25 -0500

jayess gravatar image

Hi All,

I'm building a 5DOF manipulator and haven't had much luck building an IK solver. My urdf for just the manipulator and bash script (to convert to collada, trim to 5 decimals, etc) can be found here: . The bash script is in the urdf folder. I've stripped out any links/joints that aren't part of the manipulator to simplify things.

I've tried setting a number of different orientations for the joints (so the arm isn't fully stretched out), but continue to get the same error when using the --iktests flag:

openravepy.databases.inversekinematics: testik, success rate: 0.000000, wrong solutions: 0.250000, no solutions: 0.750000, missing solution: 0.000000
Traceback (most recent call last):
  File "/usr/local/bin/", line 126, in <module>
  File "/usr/local/lib/python2.7/dist-packages/openravepy/_openravepy_0_9/databases/", line 1128, in run
  File "/usr/local/lib/python2.7/dist-packages/openravepy/_openravepy_0_9/databases/", line 1116, in RunFromParser
    raise InverseKinematicsError(u'wrong rate %f > 0!'%wrongrate)
openravepy._openravepy_0_9.databases.inversekinematics.InverseKinematicsError: Inverse Kinematics Error
wrong rate 0.250000 > 0!

Any idea what i'm doing wrong here? I built openrave from commit 9350ebc... Not sure if that's the latest working one (latest commit from master failed to build).

Appreciate any ideas at all, as I've been bashing my head for days trying to get this to work!


edit retag flag offensive close merge delete


Just making sure: you did ask IKFast to generate for a 5dof manipulator, correct?

gvdhoorn gravatar image gvdhoorn  ( 2019-01-21 04:29:47 -0500 )edit

Hello! Yep, i used the flag --iktype=translationdirection5d

robonoob gravatar image robonoob  ( 2019-01-21 04:39:26 -0500 )edit

hummm, gone ahead and built the moveit plugin anyway, and i'm able to move the interactive marker around, but the EE orientation seems to be stuck. Is this normal?

robonoob gravatar image robonoob  ( 2019-01-25 17:54:34 -0500 )edit

A 5of robot cannot reach all poses in a 6dof search space. So yes, for some poses this would be 'normal' (or really: a limitation of the kinematics of your robot).

Try with the "Approximate IK" checkbox checked.

gvdhoorn gravatar image gvdhoorn  ( 2019-01-27 03:02:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-01-27 04:09:53 -0500

robonoob gravatar image

Worked this out yesterday. When the axes of the last two joints align, the solver is generated incorrectly for some reason. I offset the last two joints with xyz coords: 0.005, 0.005, 0, and was able to generate a solver that works.

Logged an issue with more details here:

edit flag offensive delete link more


I am facing the same issue with an UR16e (6 dof robot). I checked the URDF and I believe that the axes are not aligned but I could be mistaken.

I also tried adding some small offsets to the joints, but then the solver cannot be generated.

Can you provide some more insight on what your issue was and what is the status of this bug?


leander gravatar image leander  ( 2022-07-07 07:31:32 -0500 )edit

Question Tools



Asked: 2019-01-19 17:06:50 -0500

Seen: 499 times

Last updated: Jan 27 '19