Ask Your Question
0

How to correctly link opencl with ros?

asked 2019-01-08 10:05:23 -0500

dinesh gravatar image

updated 2019-01-08 10:45:58 -0500

I just have installed opencl in my ubuntu 18 based on this tutorial. i also find similar question here but i didn't understand it properly. Here are the folders inside the workspace: image description

well i tried like below, but here only opencl_headers are not creating any error.

 include_directories(~/intel-compute-runtime/workspace/opencl_headers/CL)

 target_link_libraries(~/intel-compute-runtime/workspace/build_igc/BiFModule/clang_build/install/lib)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-01-11 11:37:38 -0500

dinesh gravatar image

updated 2019-01-11 11:38:12 -0500

This is working for me:

include_directories(
# include
  ${catkin_INCLUDE_DIRS}
  /usr/include/CL/
)
add_executable(save_pattern src/save_pattern.cpp)
target_link_libraries(save_pattern ${catkin_LIBRARIES} /usr/lib/x86_64-linux-gnu/libOpenCL.so)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-01-08 10:05:23 -0500

Seen: 330 times

Last updated: Jan 11 '19