ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

catkin_make: cmake error: cannot find stdmsgsConfig.cmake

asked 2019-01-06 09:51:12 -0500

microbot gravatar image

updated 2019-01-06 13:48:48 -0500

gvdhoorn gravatar image

I am having the following error while trying to using catkin_make for my workspace,

CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "stdmsgs" with any
  of the following names:


  Add the installation prefix of "stdmsgs" to CMAKE_PREFIX_PATH or set
  "stdmsgs_DIR" to a directory containing one of the above files.  If
  "stdmsgs" provides a separate development package or SDK, be sure it has
  been installed.

can anyone please suggest me why ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-01-06 10:45:49 -0500

jayess gravatar image

updated 2019-01-06 10:46:17 -0500

It looks like you're trying to use the stdmsgs package in your CMakeLists.txt when it should be std_msgs.

edit flag offensive delete link more


Thank you, this solved the error and also this helped me understand ros and catkin workspace a bit more. Thank you once again.

microbot gravatar image microbot  ( 2019-01-07 04:02:46 -0500 )edit

No problem, glad it worked.

jayess gravatar image jayess  ( 2019-01-07 14:01:12 -0500 )edit

Question Tools

1 follower


Asked: 2019-01-06 09:51:12 -0500

Seen: 2,175 times

Last updated: Jan 06 '19