Ask Your Question
1

Getting stuck on stuck on depth_frame_id

asked 2012-04-03 12:55:26 -0500

bub102x gravatar image

updated 2012-04-03 13:15:45 -0500

Im running the command roslaunch openni_camera openni_node.launch and this is what I am getting. I am using Ubuntu 10.10 and i have the full diamondback install... Ive been searching for answers here but havent found anything...

Only otherthing I can think of is that I am running Ubuntu off an 8gb flashdrive

ubuntu@ubuntu:~$ roslaunch openni_camera openni_node.launch
... logging to /home/ubuntu/.ros/log/83abd83a-7ddf-11e1-b9e7-001b774634f0/roslaunch-ubuntu-20385.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:52384/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [20399]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 83abd83a-7ddf-11e1-b9e7-001b774634f0
process[rosout-1]: started with pid [20412]
started core service [/rosout]
process[openni_node1-2]: started with pid [20420]
process[kinect_base_link-3]: started with pid [20425]
process[kinect_base_link1-4]: started with pid [20426]
process[kinect_base_link2-5]: started with pid [20427]
process[kinect_base_link3-6]: started with pid [20428]

[ INFO] [1333493474.709674881]: [/openni_node1] Number devices connected: 1
[ INFO] [1333493474.710057749]: [/openni_node1] 1. device on bus 001:07 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'B00361705295045B'
[ INFO] [1333493474.715158023]: [/openni_node1] searching for device with index = 1
[ INFO] [1333493474.774529804]: [/openni_node1] Opened 'Xbox NUI Camera' on bus 1:7 with serial number 'B00361705295045B'
[ INFO] [1333493474.806963725]: rgb_frame_id = '/openni_rgb_optical_frame' 
[ INFO] [1333493474.811240505]: depth_frame_id = '/openni_depth_optical_frame' 
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-03 15:09:45 -0500

Eric Perko gravatar image

That looks like perfectly normal output - you may not get any further output in the terminal if the driver is running properly.

You can verify that the driver is output point clouds by checking the /camera/rgb/points topic. To do that, in a separate terminal (while leaving the one the driver is running in open), you would run:

rostopic hz /camera/rgb/points

And that should output the rate at which the driver is publishing point clouds from the Kinect (likely 30Hz) (you may want to use rostopic list to see all of the topics the driver is publishing and select one of those - I may be slightly off on remembering what the topic that openni_camera publishes registered RGB data on).

If you get output from rostopic hz, you could view the points in rviz. To do that, follow the directions on the Diamondback version of the openni_camera docs (Section 4). Make sure you are on the Diamondback documentation by selecting diamondback at the top of the documentation.

edit flag offensive delete link more

Comments

Thanks, I will give that a try tomorrow when I have the chance to run it

bub102x gravatar image bub102x  ( 2012-04-03 17:03:09 -0500 )edit

I tried this and i am getting out put but when I try to view the points in rviz, I do as that guide says but as soon as I turn on pointcloud2 display my CPU usages jumps to 100% and stays there and the view shows very little, nothing recognisable

bub102x gravatar image bub102x  ( 2012-04-04 11:20:59 -0500 )edit

That sounds like your computer might not be able to keep up with the firehose of data from the Kinect.

tfoote gravatar image tfoote  ( 2012-04-04 12:59:57 -0500 )edit

I have an intel core 2 processor running at 2.16GHz, 2GB of ram, and a Nvidia Geforce Go 7900 GS with 256mb dedicated ram... is that not enough?

bub102x gravatar image bub102x  ( 2012-04-04 13:37:39 -0500 )edit

How much cpu does your computer use if you just do rostopic hz /camera/rgb/points? The driver only publishes if someone is subscribed, so CPU usage with no subscribers is not a good indicator. You could also play with dynamic_reconfigure to try to get CPU usage down by using lower res images.

Eric Perko gravatar image Eric Perko  ( 2012-04-04 14:01:54 -0500 )edit

runing just hz /camera/rgb/points my cp jumps up high around 80%... i tried on another laptop with a quadcore and all 4 jumped to around 60%. Im guessing there is something wrong with the install

or my other guess is that it is because I am running off an 8gb flash drive?

bub102x gravatar image bub102x  ( 2012-04-06 08:54:40 -0500 )edit

The CPU usage jump is not unexpected, the node does not actually send data unless something is subscribed. And rostopic is subscribing in a seperate process which requires serializing, sending and deserializing the point cloud stream.

tfoote gravatar image tfoote  ( 2012-04-23 07:51:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-03 12:55:26 -0500

Seen: 199 times

Last updated: Apr 06 '12

Related questions