Ask Your Question
0

Melodic network setup: invalid ROS_IP (protocol should not be included)

asked 2018-11-16 22:25:50 -0500

updated 2018-11-17 06:04:18 -0500

gvdhoorn gravatar image

I have one workspace in Raspberry Pi with Xubuntu and one in Ubuntu PC. I am running ROS Melodic on both. I am able to access Raspberry Pi through Ubuntu PC using ssh.The roscore is running in Raspberry Pi. My ~/.bashrc file settings are as below (Reference: Here):

Raspberry Pi:
source /opt/ros/melodic/setup.bash 
source ~/catkin_ws/devel_isolated/setup.bash 
export ROS_MASTER_URI=http://192.168.2.111:11311 
export ROS_IP=http://192.168.2.111

Ubuntu PC: 
source /opt/ros/melodic/setup.bash 
source ~/DKOBDR_WS/temp_ws/devel_isolated/setup.bash 
export ROS_MASTER_URI=http://192.168.2.111:11311 
export ROS_IP=http://192.168.2.70

The roscore runs in Raspberry Pi correctly, but I am getting the following output with roslaunch in Raspberry Pi:

shaunak@Xubuntu-RPi:~$ roslaunch mobile_robot_pkg keyboard_teleop.launch
... logging to /home/shaunak/.ros/log/ed3361e8-ea1a-11e8-a91e-b827ebd68f79/roslaunch-Xubuntu-RPi-2380.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

invalid ROS_IP (protocol should not be included)
invalid ROS_IP (protocol should not be included)
RLException: Unable to contact my own server at [http://http://192.168.2.111:39657/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:
    ping http

For more tips, please see

    http://www.ros.org/wiki/ROS/NetworkSetup

The traceback for the exception was written to the log file

I kindly request for some precise guideline for Network Setup as I have gone through http://wiki.ros.org/ROS/NetworkSetup and http://wiki.ros.org/ROS/Tutorials/MultipleMachines, but can not get much out of them.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-17 03:16:55 -0500

gvdhoorn gravatar image

updated 2018-11-17 03:51:38 -0500

From:

export ROS_IP=http://192.168.2.70

and:

invalid ROS_IP (protocol should not be included)

seems clear enough: http://1.2.3.4 is not a valid IP address. 1.2.3.4 would be a valid IP address. http:// is the "protocol" that the error message is referring to.

You're supposed to set ROS_IP to an IP address, not a URL.

edit flag offensive delete link more

Comments

@gvdhoorn : Thank you. It's working now.

Shaunak Agastya Vyas gravatar image Shaunak Agastya Vyas  ( 2018-11-17 04:00:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-16 22:25:50 -0500

Seen: 1,550 times

Last updated: Nov 17 '18