Ask Your Question
0

Joint trajectory controller (client) not working

asked 2018-10-17 07:16:34 -0500

Sietse gravatar image

Hello list,

Trying to get a trajectory controller working, but am unable to get a working action client. As a first test I tried to add it to the rrbot example from gazebo_ros_demos. As the rrbot_control.yaml I use the following:

 rrbot:
  # Publish all joint states -----------------------------------
  joint_state_controller:
    type: joint_state_controller/JointStateController
    publish_rate: 50  

  # Trajectory Controller  (not together with the position controllers)
  joint_trajectory_controller:
    type: effort_controllers/JointTrajectoryController
    joints:
      - joint1
      - joint2
    constraints:
      goal_time: 0.0
      stopped_velocity_tolerance: 0.01
      joint1: {trajectory: 0.01, goal: 0.01}
      joint2: {trajectory: 0.01, goal: 0.01}
    gains:
      joint1: {p: 100.0, d: 75.0, i: 0.0, i_clamp: 0.0}
      joint2: {p: 100.0, d: 25.0, i: 0.0, i_clamp: 0.0}
      state_publish_rate:  100
      action_monitor_rate: 100
      stop_trajectory_duration: 0.0

With an properly adapted launch file both controllers are loaded and started. All is well I think, but I have a problem creating a simple actionclient to use them. I actually do not know how to start the client (in Python). The client starts but noting happens, if keeps waiting for the server. The relevant line (i think) in my client is:

arm_client = actionlib.SimpleActionClient('rrbot/joint_trajectory_controller', FollowJointTrajectoryAction)

The first parameter is wrong, but what should it be? Is there an additional parameter needed in the yaml file?

Thanks in advance, Sietse

PS. Using melodic (from source) on debian test

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-17 08:13:42 -0500

gvdhoorn gravatar image

This is all very sensitive to which namespaces have been declared, where topics are located, etc.

What is the output of rostopic list | grep -i goal after you've started your simulation?

edit flag offensive delete link more

Comments

/rrbot/joint_trajectory_controller/follow_joint_trajectory/goal

And that solved my problem, thanks!

Sietse gravatar image Sietse  ( 2018-10-17 13:35:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-10-17 07:16:34 -0500

Seen: 179 times

Last updated: Oct 17 '18