ROS Kinetic+openni2+rgbdslam_V2=REQUIRED process has died!

asked 2018-10-11 11:23:54 -0600

ramromdev gravatar image

hi, I'm trying to create a 3D map from an Asus Xtion PRO Live with openni2 driver in ROS Kinetic and Ubuntu 16.04. I followed the wiki section on GitHub for the installation process of rgbdslam_v2. When I try to launch rgbdslam_v2 the GUI shows up, the images are shown correctly from the topics that I want, but when it starts processing it stops, showing the error

REQUIRED process [rgbdslam-1] has died!

What I've tried:

  • At first I had qt4 installed, but after seeing some functions in the GraphManager.cpp file from rgbdslam, I thought qt5 was needed, so I uninstalled qt4 and installed qt5. Problem remains.

  • Then I thought that the problem may come from some optimization functions. So, in my modified rgbdslam launch file, I modified the optimizer_skip_step parameter (I typed 10), and the program worked fine until it reached the 10th frame. I modified it again and the same, the program stops when it reaches the number in optimizer_skip_step.

So I'm running out of ideas. I must also say that the test_settings.launch file works fine with my own rosbag file, it seems to process and optimize it correctly. I don't know what is happening. Any suggestions? Thanks in advance.

edit retag flag offensive close merge delete