Ask Your Question
0

catkin package

asked 2018-10-07 10:01:01 -0600

Ibrahim_aerospace gravatar image

Hello respected members Recently I have frustrated situations. Suddenly something happened to my Ubuntu operating system. I cant use any command in terminal. Whenever I type command catkin_make it says that catkin_make is not installed but actually it was installed already. I install it again. But when I close the terminal and open it, the same error appears. So I searched for the solution, someone mentioned that type export PATH=/usr/bin:/bin in terminal, after this I install catkin this solves the problem but not permanently, because when i open terminal again, so the same situation occurs, I dont know what to do. Please someone help me to solve the problem. Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2018-10-08 00:54:59 -0600

gvdhoorn gravatar image

The catkin_make program is not in a directory that is on the PATH by default.

Only after having run source /opt/ros/kinetic/setup.bash will the environment in which you source that file be updated to be able to find catkin_make. You need to do this in every terminal.

You may have had the source line add the end of your $HOME/.bashrc (to avoid having to execute it in every terminal) and it got changed. I would suggest to check that you have that line there.

Suddenly something happened to my Ubuntu operating system

"something" is a bit vague: did you install any updates? Ran any forced commands with apt?

Make sure you still have ros-kinetic-catkin installed.

edit flag offensive delete link more
0

answered 2018-10-07 21:40:23 -0600

rajat7 gravatar image

updated 2018-10-07 21:50:35 -0600

Add export PATH=/usr/bin:/bin to your .bashrc like this

echo "export PATH=/usr/bin:/bin" >> ~/.bashrc

Then source the .bashrc using source ~/.bashrc or restart the terminal.

edit flag offensive delete link more

Comments

catkin_make is not on the path unless the user has source /opt/ros/$ROS_DISTRO/setup.bash. Adding /usr/bin to .bashrc doesn't change that, so I'm not sure why you are suggesting the OP to do that.

gvdhoorn gravatar imagegvdhoorn ( 2018-10-08 00:51:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-07 10:01:01 -0600

Seen: 26 times

Last updated: Oct 08 '18