Convert XACRO in URDF

asked 2018-10-03 07:29:39 -0500

marcusvini178 gravatar image

updated 2019-06-24 18:57:51 -0500

jayess gravatar image

Now I am facing a new problem, if you could help me, so I will be grateful! The problem is the following. I have constructed the robot not in URFD but in XACRO....so the tutorial says me to convert the Xacro in Urdf extension....well I tried but so the following error message appears to me on the terminal: xacro:

Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order

So, I have clicked in the link, I have read the topics and later I tried the command

rosrun xacro xacro.py --inorder pan_tilt.xacro > pan_tilt_generated.urdf

instead the original command suggested by the book

rosrun xacro xacro.py pan_tilt.xacro > pan_tilt_generated.urdf

This last command was the command that generated the error depicted above, and the first command also didn't give me a correct feedback, in other words, the xacro was not converted again in urdf.

Could someone explain me what is happening? I am not understanding...

Thanks


Update:

I forgot to entry the error message when I type the command

rosrun xacro xacro.py pan_tilt.xacro >pan_tilt_generated.urdf

The message error is:

No such file or directory: pan_tilt.xacro None None

But The file exist, and the directory too, the pan_tilt.xacro is inside the urdf directory.

edit retag flag offensive close merge delete

Comments

Are you sure this is an error message and not just a warning ?

Delb gravatar imageDelb ( 2018-10-03 07:46:18 -0500 )edit