Need help running the Driver/Nodes/Nodelets

asked 2018-09-25 13:39:22 -0600

AudCavalier gravatar image

Hello,

I'm really new using ROS, been reading a while the docs and following the tutorials and at least I feel I got a basic understanding of the core concepts (ROS, Nodes, Nodelets, Catkin workspace); Since I need to start working with the Bebop 2, I started following the installation process and the instructions on the docs ( https://bebop-autonomy.readthedocs.io... ). However there are many things I still cant figure out, and there ins't really a tutorial out there for basically "absolute beginners" like me, so I have to figure out most of the things and I just can't find a step-by-step guide or something that could give me an idea of what I'm doing wrong.

I'm running buntu 16.04 on VirtualBox (since I need to use Windows for my job), I was still able to run the Parrot SDK example without any trouble (Just connected my WIndows wifi to the Bebop, ran the example in VB's Ubuntu and it worked perfectly), but still considering it a reason of why it may not work with ROS. ROS version : Kinetic

Here is a log of what I got when trying to run the driver just as the docs say:

 roslaunch bebop_driver bebop_node.launch
... logging to /home/hypermuteki7/.ros/log/5a4e3dc2-c0ed-11e8-8ee4-080027c87d84/roslaunch-hypermuteki7-VirtualBox-5249.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
started roslaunch server http://hypermuteki7-VirtualBox:41973/
SUMMARY
========

PARAMETERS
 * /bebop/bebop_driver/bebop_ip: 192.168.42.1
 * /bebop/bebop_driver/camera_info_url: package://bebop_d...
 * /bebop/bebop_driver/cmd_vel_timeout: 0.2
 * /bebop/bebop_driver/odom_frame_id: odom
 * /bebop/bebop_driver/publish_odom_tf: True
 * /bebop/bebop_driver/reset_settings: True
 * /bebop/bebop_driver/states/enable_altitudechanged: True
 * /bebop/bebop_driver/states/enable_autotakeoffmodechanged: True
 * /bebop/bebop_driver/states/enable_camerastate_orientation: True
 * /bebop/bebop_driver/states/enable_commonstate_batterystatechanged: True
 * /bebop/bebop_driver/states/enable_commonstate_wifisignalchanged: True
 * /bebop/bebop_driver/states/enable_controllerstate_ispilotingchanged: True
 * /bebop/bebop_driver/states/enable_flightplanstate_availabilitystatechanged: True
 * /bebop/bebop_driver/states/enable_flightplanstate_componentstatelistchanged: True
 * /bebop/bebop_driver/states/enable_gpsstate_numberofsatellitechanged: True
 * /bebop/bebop_driver/states/enable_mavlinkstate_mavlinkfileplayingstatechanged: True
 * /bebop/bebop_driver/states/enable_mavlinkstate_mavlinkplayerrorstatechanged: True
 * /bebop/bebop_driver/states/enable_mediastreamingstate_videoenablechanged: True
 * /bebop/bebop_driver/states/enable_numberofsatellitechanged: True
 * /bebop/bebop_driver/states/enable_overheatstate_overheatchanged: True
 * /bebop/bebop_driver/states/enable_pilotingstate_altitudechanged: True
 * /bebop/bebop_driver/states/enable_pilotingstate_attitudechanged: True
 * /bebop/bebop_driver/states/enable_pilotingstate_flattrimchanged: True
 * /bebop/bebop_driver/states/enable_pilotingstate_flyingstatechanged: True
 * /bebop/bebop_driver/states/enable_pilotingstate_navigatehomestatechanged: True
 * /bebop/bebop_driver/states/enable_pilotingstate_positionchanged: True
 * /bebop/bebop_driver/states/enable_pilotingstate_speedchanged: True
 * /bebop/robot_description: <?xml version="1....
 * /rosdistro: kinetic
 * /rosversion: 1.12.13

NODES
  /bebop/
    bebop_driver (bebop_driver/bebop_driver_node)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)

auto-starting new master
process[master]: started with pid [5262]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 5a4e3dc2-c0ed-11e8-8ee4-080027c87d84
process[rosout-1]: started with pid [5275]
started core service [/rosout]
process[bebop/bebop_driver-2]: started with pid [5292]
process[bebop/robot_state_publisher-3]: started with pid [5293]
[ INFO] [1537898630.281022325]: Initializing nodelet with 4 worker threads.
[ INFO] [1537898630.367669610]: [BebopSDK] 13:03:50:367 | Bebop:225 - Bebop Cnstr()
[ INFO] [1537898630.367842139]: Nodelet Cstr
[ INFO] [1537898630 ...
(more)
edit retag flag offensive close merge delete

Comments

I have no experience with Bebop 2, but the first error in the log you gave says No route to host . Do you have the correct IP set for your device, looks like you still have the default IP from the launch file, not sure if that is supposed to work? Can you ping that IP from your VirtualBox?

Reamees gravatar imageReamees ( 2018-09-27 02:06:45 -0600 )edit

Tried the ping and at first didn't got any response, then I edited the VirtualBox internet configuration and finally got response from ping, after that I was finally able to run the nodelet, thanks!

AudCavalier gravatar imageAudCavalier ( 2018-09-28 18:00:54 -0600 )edit