ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem with fuerte version of ROS...

asked 2012-03-23 07:01:16 -0600

BetoCC011 gravatar image

updated 2014-04-20 14:09:38 -0600

ngrennan gravatar image

Hello guys, i'm just starting to learn ROS, but i'm having some problems following the tutorials: 1- The Turtlesim windows was supposed to show a turtle, but mine just shows the blue color. What did i do wrong? Or is it because i'm using the beta version of ROS (fuerte)?

2- The command "rosmsg show <msg name="">" doesn't work! every time i try it, it shows me: "Cannot locate message [Num] in package [beginner_tutorials] with paths [/home/beto/ros_workspace/beginner_tutorials/msg]", but in this folder there is the msg Num.msg, what am I doing wrong?

3- The command "roswtf" tells me: "ROS_ROOT is invalid: ROS_ROOT [/opt/ros/fuerte] must end is directory named 'ros'", but this is the directory, i dont know why its telling me this.

One last thing, the tutorial tells me to execute this file:, that contains this text: " #!/bin/sh source /opt/ros/fuerte/setup.bash export ROS_ROOT=/opt/ros/fuerte export PATH=$ROS_ROOT/bin:$PATH export PYTHONPATH=$ROS_ROOT/core/roslib/src:$PYTHONPATH export ROS_PACKAGE_PATH=~/ros_workspace:/opt/ros/fuerte/stacks:$ROS_PACKAGE_PATH export ROS_WORKSPACE=~/ros_workspace"

But i'm not sure this is the version for the fuerte version of Ros, because i just copied the electric version and changed a little bit so it would work on ros, maybe that's why im having those problems.

Thanks everyone.. :)

edit retag flag offensive close merge delete


I'm using fuerte because my teacher recommended :) I'm doing my scientific initiation and he needs me to know how to use the fuerte version, how different are they?

BetoCC011 gravatar image BetoCC011  ( 2012-03-23 07:09:45 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2012-03-23 07:03:58 -0600

kwc gravatar image

updated 2012-03-23 08:18:56 -0600

You probably shouldn't be using Fuerte, which is not yet released, if you are still learning ROS. At a glance, there are numerous possible configuration issues in your setup and they probably aren't worth debugging, given that you can just use Electric. Fuerte will be released in mid-April.

Update: Fuerte is very different at the package system level, so configuration is completely different. It is backwards compatible with Electric, but the configuration comes from entirely different files, so you are likely to encounter issues if you attempt a straight 1-to-1 conversion of your environment setup.

edit flag offensive delete link more

answered 2012-05-02 11:34:32 -0600

mwalk gravatar image

I too am trying to learn ROS using FUERTE and have experienced the same problems mentioned above. I found I could still follow along with the tutorials, without the turtlesim working completely.

However, upon completion of those tutorials I tried to download my first few packages from the repositories to no avail. I was unable to download the wg-ros-pkg with "apt-get install wg-ros-pkg". Is there a different way of doing this? I also tried "apt-get install ros-fuerte-wg-ros-pkg"

edit flag offensive delete link more


If you're having trouble, please post a new question. Posting a question as an "answer" to an answered question won't get the response you're looking for. Also remember to make sure to describe what you're doing so others can reproduce.

tfoote gravatar image tfoote  ( 2012-05-02 15:54:20 -0600 )edit

answered 2012-05-02 10:36:03 -0600

ezex gravatar image

im having the same problem, The Turtlesim windows was supposed to show a turtle, but mine just shows the blue color.

but now FUERTE IS the last release of ROS, but the tutorial with turtlesim is not working as expected , im using UBUNTU 11.10 . The Turtlesim windows was supposed to show a turtle, but mine just shows the blue color.

any suggestions ? , as I know is only for learning pourposes, but if this doesn't work im afraid that future errors will be dificult to solve as I dont know if I have a right installation or not.

edit flag offensive delete link more

Question Tools


Asked: 2012-03-23 07:01:16 -0600

Seen: 843 times

Last updated: May 02 '12