Ask Your Question
0

ROS Kinetic Installation stuck on std_msgs

asked 2018-09-17 09:29:15 -0500

Gregg gravatar image

I'm trying to install ROS kinetic onto my raspberry pi 3b+. It's running raspbian jessie. But it gets stuck when processing catkin package std_msgs. It'll get to [100%] Built target std_msgs_generate_messages_cpp and just stay there for hours. I've already tried increasing the swap space but that didn't help. Does anyone have any suggestions?

edit retag flag offensive close merge delete

Comments

Have you tried to see whether catkin_make -j1 succeeds? If so, it could be a resource problem.

(I'm assuming you're using catkin_make here, not catkin_tools)

gvdhoorn gravatar imagegvdhoorn ( 2018-09-17 10:00:50 -0500 )edit

Forgive me, I'm very new at this so how could I tell if catkin_make -j1 succeeds?

Gregg gravatar imageGregg ( 2018-09-17 10:11:15 -0500 )edit

If it doesn't hang your build?

gvdhoorn gravatar imagegvdhoorn ( 2018-09-17 10:12:52 -0500 )edit

I'm using the tutorial here: http://wiki.ros.org/ROSberryPi/Instal...

step 3.3 is where it's getting stuck at, what step would I check for catkin_make -j1?

Gregg gravatar imageGregg ( 2018-09-17 10:15:59 -0500 )edit

You're using catkin_make_isolated, so just adjust the command to use -j1 instead of the -j4 that is shown in that tutorial.

gvdhoorn gravatar imagegvdhoorn ( 2018-09-17 10:23:33 -0500 )edit

I tried that now, it seems to have gotten stuck at [ 60%] Generating EusLisp manifest code for std_msgs The strange thing is that the cpu usage has fallen to zero so the raspberry pi doesn't seem to be doing anything

Gregg gravatar imageGregg ( 2018-09-17 11:13:48 -0500 )edit

Well it was worth a shot. I'm not sure what the issue is now. Perhaps you could try strace.

gvdhoorn gravatar imagegvdhoorn ( 2018-09-17 12:31:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-08 19:26:48 -0500

I know this is going to be the answer no one want to use, but in my case, this solve my problem (so please, no hate).

I do not know if my problem is the same as yours (but have similar syntoms) in my case, I am using gentoo (which I know the support is experimental), I tried with kinetic and melodic and both cases had same problem catkin_make -j1 was getting stuck at Generating EusLisp manifest and this just happened with packages that have to compile msgs

since I don't really care about having ROS-EusLisp compatibility, I modified /opt/ros/kinetic/lib/geneus/gen_eus.py and commented the line geneus.geneus_main.genmain(sys.argv, 'gen_eus.py')

After that everything worked fine.

edit flag offensive delete link more

Comments

If you're going to disable message generation for (a) certain language, then I would recommend you do it using the official support for that. Refer to #q213511.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-09 02:17:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-09-17 09:29:15 -0500

Seen: 185 times

Last updated: Sep 17 '18