Ask Your Question
1

map_server segfaults [closed]

asked 2018-09-10 18:55:22 -0500

Michael Chen gravatar image

updated 2018-09-11 03:23:18 -0500

mgruhler gravatar image

Hello,

I have been having an issue with the "rosrun map_server map_server map.yaml" command. I have ros kinetic on Ubuntu 16.04 running on a Jetson Tx2. Every time I run the command, the console tells me there has been a “segmentation fault (core dumped).” Here is the link to page with the map.yaml file: https://github.com/mit-racecar/raceca... . Is there something wrong with the formatting of the yaml files or is it something else? Also, if I have to build map_server from source, what command would I use to do so.

Thank you, Michael Chen

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by allenh1
close date 2018-09-13 11:14:20.606543

Comments

1

I tried to look into that and could actually reproduce the problem. But updating all debian packages fixed it. I'm not sure what the problem has been, I'm assuming some problem with dependencies, but cannot pinpoint it. Maybe @David Lu has some more insights?

Please report if upgrade don't fix it

mgruhler gravatar image mgruhler  ( 2018-09-11 03:30:56 -0500 )edit

Thanks for the insight! How would I update the debian package? I am unfamiliar with some of this.

Michael Chen gravatar image Michael Chen  ( 2018-09-11 07:27:25 -0500 )edit
1

sudo apt update && sudo apt upgrade

mgruhler gravatar image mgruhler  ( 2018-09-11 08:02:06 -0500 )edit

It worked! Thank you.

Michael Chen gravatar image Michael Chen  ( 2018-09-11 18:11:25 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-09-12 00:59:46 -0500

mgruhler gravatar image

This seems to have been a dependency issue and can be resolved by updating the respective debian packages.

edit flag offensive delete link more

Comments

It could well be that this was caused by the same (presumed) ABI incompatibility that lead to #q303093 being posted.

gvdhoorn gravatar image gvdhoorn  ( 2018-09-12 02:22:28 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2018-09-10 18:55:22 -0500

Seen: 1,172 times

Last updated: Sep 12 '18