Ask Your Question
1

ROS2 Windows failed to load shared library of rmw implementation

asked 2018-08-21 10:01:39 -0500

EricB gravatar image

I am following the Windows install instructions. When I try to run the talker, I get the following error (multiple times):

'failed to load shared library of rmw implementation. Exception: Cannot load library: C:\Users\xxxx\Source\External\ros2-windows\bin/rmw_fastrtps_cpp.dll, at C:\J\workspace\ci_packaging_windows\ws\src\ros2\rmw_implementation\rmw_implementation\src\functions.cpp:135'

The file 'rmw_fastrtps_cpp.dll' is installed in that location. I am on Windows 10 with all the updates using the most recent version of ROS2 and other files as directed by the installation instructions.

Troubleshooting advice would be helpful!

Cheers, Eric

edit retag flag offensive close merge delete

Comments

Did you source the setup.bat file? It's required because it adds folders to the PATH which is what Windows uses to find .dll files.

William gravatar imageWilliam ( 2018-08-21 15:00:23 -0500 )edit

(thanks for replying, William)

Yes, I still encounter the problem. There is really nothing in the error that helps me fix the issue. If there is a missed step or other common issue, I'd like to update the Windows install docs to help others.

I got it to install just fine on Ubuntu.

EricB gravatar imageEricB ( 2018-08-21 15:16:38 -0500 )edit

Is the root in that weird combination of "\" and "/" in your path?

Marcel Usai gravatar imageMarcel Usai ( 2018-08-28 07:39:06 -0500 )edit

I found my question to be about the same issue. Wheneyer I want to call rclpy.init, this error occurs. Even when publishing from command line. Maybe this is a compilation issue? Did you compile from source?

Marcel Usai gravatar imageMarcel Usai ( 2018-09-04 03:33:36 -0500 )edit

@EricB Does the answer from https://answers.ros.org/question/3021... also fixes this issue ?

marguedas gravatar imagemarguedas ( 2018-09-10 18:31:22 -0500 )edit

I have the same problem. Is here any solution?

yaonan_zhu gravatar imageyaonan_zhu ( 2018-11-01 23:01:23 -0500 )edit

Same problem here. Using a english locale does not solve the issue. Any news?

VictorLamoine gravatar imageVictorLamoine ( 2019-05-14 08:35:07 -0500 )edit

Sorry for the late reply. I then switched back to ROS and did not try any further.

Marcel Usai gravatar imageMarcel Usai ( 2019-08-09 03:56:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-05 07:43:06 -0500

PratNag gravatar image

I had the exact same issue. I was sure I followed all installation correctly for
https://index.ros.org/doc/ros2/Instal....

I then had to build from source and now everything works fine. https://index.ros.org/doc/ros2/Instal...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2018-08-21 10:01:10 -0500

Seen: 587 times

Last updated: Jun 05