ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

For frame [laser]: Frame [laser] does not exist

asked 2018-08-07 20:57:24 -0500

frodyteen gravatar image

I am running ubuntu 14.4 indigo. I downloaded this line extraction packet.. I then roslaunch husky_gazebo husky_playpen.launch and roslaunch husky_viz view_robot.launch to start a husky simulation. Then, I followed the line extraction package instruction and started roslaunch example.launch. I checked that both /line_segments and /line_markers are giving me outputs by rostopic echo. Now, I am trying to make the line marker show up on rivz, but I am running into the following error when I added the marker For frame [laser]: Frame [laser] does not exist a picture is shown below: image description

anyone have suggestions on this? thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-07 21:17:54 -0500

stevejp gravatar image

The line extraction node is trying to publish the markers in the laser frame, which doesn't exist because you probably haven't provided a transform. You should set the frame_id parameter (see package parameter definitions here) to a frame which is defined in your tf_tree.

edit flag offensive delete link more

Comments

thank you!

frodyteen gravatar image frodyteen  ( 2018-08-07 21:38:19 -0500 )edit

Hi, I set the frame_id parameter but as soon as I add the marker display, Rviz crashes, what could it be due to?

mattewthep gravatar image mattewthep  ( 2020-05-09 06:36:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-07 20:57:24 -0500

Seen: 2,637 times

Last updated: Aug 07 '18