Ask Your Question
0

Remote run "rosrun rviz rviz" to Ubuntu 14.04 LTS ROS indigo

asked 2018-08-07 07:19:15 -0500

kkk003 gravatar image

Hi Guys

I am using Ubuntu 14.04 LTS ROS indigo as robot machine connected to internal WLAN server. I need to run this machine remotely and access the rviz visualization. I choose Windows 10 'Remote Desktop Connection' to connect to Ubuntu 14.04 LTS ROS indigo, Everything is setup perfectly ROS_HOSTNAME, ROS_IP and ROS_MASATER_URI.

But when I run Rosrun Rviz Rviz I get the following Multiple errors

Xlib:  extension "XInputExtension" missing on display ":10.0".
[ INFO] [1533643820.642273943]: rviz version 1.11.19
[ INFO] [1533643820.642353535]: compiled against Qt version 4.8.6
[ INFO] [1533643820.642368853]: compiled against OGRE version 1.8.1 (Byatis)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast 
Segmentation fault

Kindly give some suggestions I am stuck big time looked up everywhere could not find solutions thanks for help

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-07 10:47:46 -0500

gvdhoorn gravatar image

The problem is most likely not your network setup, but the fact that you're using a VNC connection (or similar tech with RDC). The display / driver used for that does not support the minimum level of OpenGL needed for RViz to render things correctly.

edit flag offensive delete link more

Comments

Funny thing is I have Nvidia Graphic Card GeForce GT 525M on Windows 10 Machine, But when I run

kkk003 gravatar image kkk003  ( 2018-08-07 15:18:21 -0500 )edit

It doesn't really matter what graphics hardware you have on your Win10 machine. It's a software configuration issue mostly.

Provided the VNC connection is the problem, two things I can think of:

  1. use an X client on Win10 with OpenGL support
  2. use a VNC server+client with OpenGL support
gvdhoorn gravatar image gvdhoorn  ( 2018-08-07 15:20:17 -0500 )edit

glxgears is working when I run the command from Windows Machine, but somehow Rviz crashes Thank you for the suggestion I will try with VNC server+client OpenGL.

kkk003 gravatar image kkk003  ( 2018-08-07 16:00:24 -0500 )edit

glxgears can probably use software rasterisation, or is content with the level of opengl support in whatever driver/display is used by VNC.

gvdhoorn gravatar image gvdhoorn  ( 2018-08-08 03:50:07 -0500 )edit

UPDATE 2: I changed my client to VNC Server and client using tightVNC, I get different errors this timeXlib:extension "RANDR" missing on display ":1". Xlib:extension "XInputExtension" missing on display ":1". [ INFO] [1533721387.945348129]: rviz version 1.11.19 Segementation fault

kkk003 gravatar image kkk003  ( 2018-08-08 09:05:35 -0500 )edit

I feel it has something to do with Xlib: extension "XInputExtension" missing on display this error is repeating. Could you explain what this means. There are no libGL errors this time only Xlib error.

kkk003 gravatar image kkk003  ( 2018-08-08 09:08:56 -0500 )edit

UPDATE 3: I tried with X client on Win10 with OpenGL support. It is working but very very slow. I will try to use other clients to speed up the process I have NX,MobaXterm in my mind.

kkk003 gravatar image kkk003  ( 2018-08-09 08:30:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-07 07:17:57 -0500

Seen: 440 times

Last updated: Aug 07 '18