HectorSLAM catkin_make crashes Pi - Can I copy workspaces? [closed]

asked 2018-08-07 02:21:47 -0500

TintinQuarantino gravatar image

Hey guys I'm relatively new to ROS so my understanding may be a bit average but here's my situation.

I'm trying to build an autonomous car using RPLiDAR and Hector slam with a Raspberry Pi as the onboard processor. I'm running ROS Kinetic and Ubuntu Mate). When I try to build a catkin workspace with the hector SLAM and RPLiDAR packages the Pi crashes at 5%. I've tried the -j1 option with catkin_make and the build process gets to about 90% and crashes again. I assume this is because the Pi doesn't have the processing power to handle this task.

I have two solutions in mind. I've built the same workspace on my laptop and it works but when I copy it to my Pi and try to run it i get an error saying the file doesn't exist. Is it possible to simply copy a prebuilt catkin workspace to another machine and use it?

Another solution I'm thinking of is to run the workspace on my laptop and retrieve the USB data from the Pi over SSH to build the maps. Is this possible?

Hopefully this isn't too much rambling its my first post thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by TintinQuarantino
close date 2018-08-13 22:37:47.876383

Comments

1

Please make sure you have enabled swap on your RPi. Without it, compilation of any serious program will always crash.

gvdhoorn gravatar imagegvdhoorn ( 2018-08-07 02:23:24 -0500 )edit
1

re: copying: no, not without doing something called cross-compiling.

gvdhoorn gravatar imagegvdhoorn ( 2018-08-07 02:23:45 -0500 )edit

Hey gvdhoorn thanks for your response! I tried using cmake again on the workspace that got up to 90% after rebooting and it worked fine. I didn't see your response before I tried this but will keep it in mind in future!

TintinQuarantino gravatar imageTintinQuarantino ( 2018-08-13 22:37:40 -0500 )edit

Hi TintinQuarantion I have the same problem here, can you share the solution how to fix this problem? thank you

nadiah gravatar imagenadiah ( 2019-05-15 20:48:58 -0500 )edit