Ask Your Question
0

roswtf service malfunctioning error

asked 2018-07-27 17:26:16 -0500

AmateurHour gravatar image

updated 2018-07-31 11:52:43 -0500

Hello! I have been experimenting with namespaces for my two turtlebot3s. Everything seemed to be fine when I launched and sshed, but when I went to run some gmapping code, I noticed I was missing some nodes in view_frames for my 2nd bot. This only happens when I run the bringup remote.launch code from a launch script that automatically ssh's into the bot. If I manually ssh and run the remote.launch, these errors do not manifest. When I ran roswtf, I discovered the following errors. I've already double checked the IP addresses and ros_master_uri. Any thoughts on how to troubleshoot this? Thank you! The launch file:

<launch>
    <!-- Robot1 -->
    <!-- may need to remove ns from group tag-->
    <group ns="bot1">
        <machine name="bot1" address="10.1.xxx.xx" user="user" password="password" default="true" env-loader="~/catkin_ws/devel/env.sh"/>
        <node pkg="rosserial_python" type="serial_node.py" name="turtlebot3_core" output="screen">
            <param name="tf_prefix" value="bot1_tf" />
            <param name="port" value="/dev/ttyACM0"/>
            <param name="baud" value="115200"/>
        </node>
        <node pkg="hls_lfcd_lds_driver" type="hlds_laser_publisher" name="turtlebot3_lds" output="screen">
            <param name="port" value="/dev/ttyUSB0"/>
            <param name="frame_id" value="/bot1_tf/base_scan"/>
            <param name="tf_prefix" value="bot1_tf" />
        </node>
        <node pkg="turtlebot3_bringup" type="turtlebot3_diagnostics" name="turtlebot3_diagnostics" output="screen">
            <param name="tf_prefix" value="bot1_tf" />
        </node>
    </group>
</launch>

The errors:

ERROR The following nodes should be connected but arent:
 * /bot1/turtlebot3_diagnostics->/rosout (/rosout)
 * /bot1/turtlebot3_lds->/rosout (/rosout)
 * /bot1/turtlebot3_core->/rosout (/rosout)

ERROR Errors connecting to the following services:
 * service [/bot1/turtlebot3_core/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/bot1/turtlebot3_core/set_logger_level], address [rosrpc://turtlebot:37186]
 * service [/bot1/turtlebot3_lds/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/bot1/turtlebot3_lds/set_logger_level], address [rosrpc://turtlebot:34368]
 * service [/bot1/turtlebot3_lds/get_loggers] appears to be malfunctioning: Unable to communicate with service [/bot1/turtlebot3_lds/get_loggers], address [rosrpc://turtlebot:34368]
 * service [/bot1/turtlebot3_core/get_loggers] appears to be malfunctioning: Unable to communicate with service [/bot1/turtlebot3_core/get_loggers], address [rosrpc://turtlebot:37186]
 * service [/bot1/turtlebot3_diagnostics/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/bot1/turtlebot3_diagnostics/set_logger_level], address [rosrpc://turtlebot:51942]
 * service [/bot1/turtlebot3_diagnostics/get_loggers] appears to be malfunctioning: Unable to communicate with service [/bot1/turtlebot3_diagnostics/get_loggers], address [rosrpc://turtlebot:51942]
edit retag flag offensive close merge delete

Comments

So a ping turtlebot works? On all involved hosts?

gvdhoorn gravatar image gvdhoorn  ( 2018-07-29 03:26:05 -0500 )edit

@gvdhoorn yes, I was even able to run tele-op on it!

AmateurHour gravatar image AmateurHour  ( 2018-07-29 08:47:33 -0500 )edit

You write that you "checked all IP addresses", but have you also configured either ROS_IP or ROS_HOSTNAME with the correct values?

gvdhoorn gravatar image gvdhoorn  ( 2018-07-31 12:16:34 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-08-01 22:08:01 -0500

AmateurHour gravatar image

In my case, this was due to network configuration. I had my turtlebotbots all named the same thing in the /etc/hosts file on my remote pc. Changing those names to something unique, and then doing the same in the turtlebot’s /etc/hosts and /etc/hostname files fixed the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-27 17:26:16 -0500

Seen: 623 times

Last updated: Aug 01 '18