Ask Your Question
1

audio_capture / audio_playback not working

asked 2011-10-21 04:44:36 -0500

River gravatar image

I have been following the audio_common tutorial.

I run:

gst-launch-0.10 alsasrc ! audioconvert ! audioresample ! alsasink

and it works correctly.

When I continue the next steps,

roslaunch audio_capture capture.launch

roslaunch audio_play play.launch

no sound is played back.

When I check the topics, /audio is there and generating values. rxgraph shows them connected. But, when I run roswtf, I get:

ERROR The following nodes should be connected but aren't:

* /audio_capture->/audio_play (/audio)

I am running on Natty.

Any help is appreciated. Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-12-21 15:30:31 -0500

tfoote gravatar image

This sounds like a network setup issue. See http://www.ros.org/wiki/ROS/NetworkSetup

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-21 04:44:36 -0500

Seen: 393 times

Last updated: Dec 21 '12