Ask Your Question
0

Setting use_sim_time without launching separate roscore

asked 2018-07-21 17:24:59 -0500

achille gravatar image

updated 2018-08-16 17:23:30 -0500

To get Rviz to play my rosbags correctly after the first loop (using arguments loop, pause, and clock), I have to start a separate roscore and do rosparam set use_sim_time true. Setting this param in a launch file that launches Rviz and the rosbag play command doesn't work: After the first loop the /tf transforms aren't published correctly anymore.

Can I do this in one launch file somehow?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-11-08 11:40:38 -0500

ticotico gravatar image

Yes, use a launch file. Just add the following line:

<param name="use_sim_time" value="true"/>

Cheers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-21 17:24:59 -0500

Seen: 500 times

Last updated: Nov 08 '21